summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-27 23:45:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-27 23:48:53 +0100
commit1317b212e93713470d7bfeea58d06338a6841ef2 (patch)
tree8e0adca42db2e5926ad9006a8985c5424a713e8a
parentsci-mathematics/gretl: add 2021d, drop 1.9.90 (diff)
downloadgentoo-1317b212.tar.gz
gentoo-1317b212.tar.bz2
gentoo-1317b212.zip
net-misc/gallery-dl: bump to 1.19.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.19.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 88be233ad842..213c1db6c382 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,3 +1,4 @@
DIST gallery-dl-1.17.5.tar.gz 359212 BLAKE2B 12c8ba8e25e8979cb9230283b40f9e11c23032f281cdf73975b1099c76d9007c68246be0e961d29d4686ce12790cf31c4ed0e3c83d91984ce11b0008176157a3 SHA512 c630156c3b16499f33d3850935f5f37d85a443041448f1edf5d0b91a36b8b73a83248a9b2f6da99d5c679b6d1759100eb42f6b50650b914f67c1928e2491bf00
DIST gallery-dl-1.18.1.tar.gz 368692 BLAKE2B f92eb7a876563ed5bc78ca1222b8c45fe78ad6d899a55bf2edefece14209acfc784bc3ac84c7e84397746f5a5ab01c2c6f94efcb0f28d2aacac3cbd68ebcd545 SHA512 20e4f983160870a646a66963505d2c53f5498b9bbbb869a603ae53848ee788f26c6df4c5951805d99f225954ddbe692c2da5501a409650cc3e522d97f34a7c0d
DIST gallery-dl-1.19.2.tar.gz 393664 BLAKE2B cae6b2cdd9f940892032498c0450918481aea22a701b236f580e6c7d2f77b7ce5fb2336a93c882b35063eb0193b9ebb956f8d12e8b6794255318b6eb65ee9de9 SHA512 7aa014e0e84d856bd9ca45131baed513f1d3c73c1500df32c39b5a40f17cd951e80b819130254f9b563a504866e5feebabf6b5c8bf517a43a6ad7a15e41f0476
+DIST gallery-dl-1.19.3.tar.gz 399869 BLAKE2B cef40ac7759bffb42536fed866df946e6c22e333ddae98db149109779dd9439c775722b887898e322de26860aee0990a440aa0812620dadb9d223da09f25d662 SHA512 b50c0e341a0b2b08ddd8f5674c1f4df097b862827f8bca2270d3fd62be619fab8a4c097de9d3193e8161ebcb64eb6c77676c243bca4cabc7dc1d3f192b485ad3
diff --git a/net-misc/gallery-dl/gallery-dl-1.19.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.19.3.ebuild
new file mode 100644
index 000000000000..79c29ccc0450
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.19.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}