summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-17 03:01:10 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-17 03:12:21 +0300
commit131c0448ac92a8571ccfff21de931777f9a1405c (patch)
tree3d8e0be10dc6d2a9f025f6e025ae20f4dbc64fd3
parentnet-misc/spice-gtk: version bump to 0.35 (diff)
downloadgentoo-131c0448.tar.gz
gentoo-131c0448.tar.bz2
gentoo-131c0448.zip
sys-apps/accountsservice: security bump to 0.6.50
Bug: https://bugs.gentoo.org/659916 Package-Manager: Portage-2.3.46, Repoman-2.3.10
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.50.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index 2e0a9fdecf90..3f86949ecd79 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1 +1,2 @@
DIST accountsservice-0.6.45.tar.xz 382740 BLAKE2B ce88e53c7d0187f53ed0a2758f81c8e2d1083ab1c95ec6cddebb2167b36706b1537ecf74b7904a9002c6179cfdf811a3268451af9443727ba9793a9af06cf8aa SHA512 09975f9fa03a3177d923de6d6f6e6acfffeb2ff4924c45eaac78c994c16974427c8e936a87034747ba494d2bb3df6e8a92ff44db387761b06e06e311d7cf105a
+DIST accountsservice-0.6.50.tar.xz 384484 BLAKE2B 52c06ba85498f292204834f967211d8f0940786dc2ea3070124d3aecccd551375bfbc8fc31f23a2c3c86e23359294307656c3b927c4e819fc102d8626ae0dd82 SHA512 6e07cd318452b1cbedeacd729f0ebb200525caf1b09981abb2bac16fd90756a790ebec08aca0a0cea016f14ab27c159a68fe1332ef4bc636c5863b8c61040f64
diff --git a/sys-apps/accountsservice/accountsservice-0.6.50.ebuild b/sys-apps/accountsservice/accountsservice-0.6.50.ebuild
new file mode 100644
index 000000000000..0b54f0f7bc24
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-0.6.50.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc elogind +introspection selinux systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+CDEPEND="
+ >=dev-libs/glib-2.44:2
+ sys-auth/polkit
+ elogind? ( >=sys-auth/elogind-229.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ systemd? ( >=sys-apps/systemd-186:0= )
+ !systemd? ( !elogind? ( sys-auth/consolekit ) )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-accountsd )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.35-gentoo-system-users.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-more-warnings \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-admin-group="wheel" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(use_enable doc docbook-docs) \
+ $(use_enable elogind) \
+ $(use_enable introspection) \
+ $(use_enable systemd)
+}