summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-25 20:58:56 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-26 11:37:45 +0200
commit131f5e3f0227725681da9fb3b65dacb309a1b049 (patch)
tree1df318b1d9eb3e612677b2e00c15c9d058d96dd5
parentdev-perl/gnome2-vfs-perl: Bump to version 1.83.0 (diff)
downloadgentoo-131f5e3f.tar.gz
gentoo-131f5e3f.tar.bz2
gentoo-131f5e3f.zip
games-arcade/tuxanci: Port to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429-r1.ebuild59
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429.ebuild72
-rw-r--r--games-arcade/tuxanci/tuxanci-99999999.ebuild59
3 files changed, 82 insertions, 108 deletions
diff --git a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
new file mode 100644
index 000000000000..3d55994e39ee
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
+HOMEPAGE="http://www.tuxanci.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
+else
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
+
+# >=x11-libs/cairo-1.8.8[X,svg]
+RDEPEND="
+ !dedicated? (
+ >=media-libs/fontconfig-2.7.0
+ media-libs/libsdl[X,opengl?]
+ media-libs/sdl-ttf[X]
+ >=media-libs/sdl-image-1.2.10[png]
+ sound? (
+ >=media-libs/sdl-mixer-1.2.11[vorbis]
+ )
+ )
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DBUILD_SERVER=$(usex dedicated)
+ -DWITH_NLS=$(usex nls)
+ -DWITH_PHYSFS=$(usex physfs)
+ -DWITH_OPENGL=$(usex opengl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DDEVELOPER=$(usex debug)
+ -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
+ -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
+ -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
+ -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
+ -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_CONF_PATH="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}
diff --git a/games-arcade/tuxanci/tuxanci-20110429.ebuild b/games-arcade/tuxanci/tuxanci-20110429.ebuild
deleted file mode 100644
index 0a18633e815e..000000000000
--- a/games-arcade/tuxanci/tuxanci-20110429.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-[[ ${PV} = 9999* ]] && GIT="git-2"
-EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
-
-inherit games cmake-utils ${GIT}
-
-DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
-HOMEPAGE="http://www.tuxanci.org/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-LICENSE="GPL-2"
-
-SLOT="0"
-IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
-
-# >=x11-libs/cairo-1.8.8[X,svg]
-RDEPEND="
- !dedicated? (
- >=media-libs/fontconfig-2.7.0
- media-libs/libsdl[X,opengl?]
- media-libs/sdl-ttf[X]
- >=media-libs/sdl-image-1.2.10[png]
- sound? (
- >=media-libs/sdl-mixer-1.2.11[vorbis]
- )
- )
- physfs? ( dev-games/physfs[zip] )
- !physfs? ( >=dev-libs/libzip-0.9 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-src_configure() {
- local mycmakeargs+=(
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_build dedicated SERVER)
- $(cmake-utils_use_with nls)
- $(cmake-utils_use_with physfs)
- $(cmake-utils_use_with opengl)
- $(cmake-utils_use_enable ipv6)
- $(cmake-utils_use debug DEVELOPER)
- )
-
- mycmakeargs+=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
- "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
- "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
- "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
- "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
- "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- prepgamesdirs
-}
diff --git a/games-arcade/tuxanci/tuxanci-99999999.ebuild b/games-arcade/tuxanci/tuxanci-99999999.ebuild
index 8d85ddeeebb7..3d55994e39ee 100644
--- a/games-arcade/tuxanci/tuxanci-99999999.ebuild
+++ b/games-arcade/tuxanci/tuxanci-99999999.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-[[ ${PV} = 9999* ]] && GIT="git-2"
-EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
-
-inherit games cmake-utils ${GIT}
+inherit cmake-utils
DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
HOMEPAGE="http://www.tuxanci.org/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
else
- SRC_URI="http://download.${PN}.org/${P}.tar.bz2"
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
@@ -42,31 +40,20 @@ DEPEND="${RDEPEND}
"
src_configure() {
- local mycmakeargs+=(
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_build dedicated SERVER)
- $(cmake-utils_use_with nls)
- $(cmake-utils_use_with physfs)
- $(cmake-utils_use_with opengl)
- $(cmake-utils_use_enable ipv6)
- $(cmake-utils_use debug DEVELOPER)
- )
-
- mycmakeargs+=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
- "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
- "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
- "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
- "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
- "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DBUILD_SERVER=$(usex dedicated)
+ -DWITH_NLS=$(usex nls)
+ -DWITH_PHYSFS=$(usex physfs)
+ -DWITH_OPENGL=$(usex opengl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DDEVELOPER=$(usex debug)
+ -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
+ -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
+ -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
+ -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
+ -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_CONF_PATH="${EPREFIX}"/etc
)
-
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
-
- prepgamesdirs
-}