summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-01 03:39:32 +0100
committerSam James <sam@gentoo.org>2022-08-01 04:14:23 +0100
commit1324b8c51e25a45bde8c74c017016977ce13f25a (patch)
tree9de211ae2dfdbe30e1596c6c3e5c4cd0447d4abf
parentwww-apps/icingaweb2: 2.11.0 stable amd64/x86 (diff)
downloadgentoo-1324b8c5.tar.gz
gentoo-1324b8c5.tar.bz2
gentoo-1324b8c5.zip
media-libs/harfbuzz: add 5.1.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-5.1.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 0784712a275b..1022623cb7c2 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,3 +1,4 @@
DIST harfbuzz-4.3.0.tar.gz 29200217 BLAKE2B dfe5e3b47e3d89a5ad7c6eaf6d274027a0eb05d1994b922d3124c97270f34353384c0161d8815fb2e379e82c8bdf046843902ba53db38daa4348e99d99255900 SHA512 bccf7cfb06ac18a9a9bf465c30dbfb51d73762a6667b3a069a85f9f597e6d27858e9e39a36cce12e23ec5b002b9e572638bf00c76bdea66545ae67a2bb7915f4
DIST harfbuzz-4.4.1.tar.gz 29231251 BLAKE2B 3947084ea2eedd76d64acfc5286ecd14d772ce0507163bc2c54a86579556a8799959ff4d47ea2919ee8472f8fe50d0266d325e3d0a7024f2ae8dcdf48d14f37e SHA512 bbc415d7b74408b1e8d34bfbc19a3cab002471fdd56d71b469c3129f0eae5532d5c7aaae7bb5cc3942fea6008d2ed9e96a7b20b10f4f5e46db63cecfa5c0248e
DIST harfbuzz-5.0.1.tar.gz 29291175 BLAKE2B a30512dbceba7eb339164cfe77685e6ccd8338c297a080341236e90bbcf7451eb27d5227422e040d92ff4267f4d97c377a66cdcaff45ea2b1e69de0602047ae0 SHA512 9d05b97dfce248634b6b3ff69fac5cc344f0c8265bf05595b74b0b060049dba082d358184662b8ea045cd51c3d07e7c4a4804513052094566b777c33ec5af89c
+DIST harfbuzz-5.1.0.tar.gz 29358116 BLAKE2B 006e66e9c76b505214b948c7c8756af38171b85cc865923e4665a4dd3eb14d89d20456ad4490b11208d57d056b087da78e1742141e41f8a22e644f20d3ea4851 SHA512 bdd7c2ca0b6f2a3a3fffbf0324d3c8bfd64a1753314048f6f67f901d4098e90054eeda9155d134f03c5d3ddefb15e087f872d2d87b2ace07bac6625fb43c7f3e
diff --git a/media-libs/harfbuzz/harfbuzz-5.1.0.ebuild b/media-libs/harfbuzz/harfbuzz-5.1.0.ebuild
new file mode 100644
index 000000000000..c3af9764765b
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-5.1.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+# 0.9.18 introduced the harfbuzz-icu split; bug #472416
+# 3.0.0 dropped some unstable APIs; bug #813705
+SLOT="0/4.0.0"
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ # bug #726120
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die
+
+ # bug #618772
+ append-cxxflags -std=c++14
+
+ # bug #790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ # bug #762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for introspection, bug #535852
+ local emesonargs=(
+ -Dcoretext="disabled"
+ -Dchafa="disabled"
+
+ $(meson_feature glib)
+ $(meson_feature graphite graphite2)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature cairo)
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+
+ $(meson_use experimental experimental_api)
+ )
+
+ meson_src_configure
+}