summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-16 08:49:59 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-16 08:49:59 +0100
commit1345d0001598cd9960d6d63e69721d959e643154 (patch)
tree1b0eb035d6ecd7b2ae7762648bf6778be786e606
parentnet-fs/samba: Fix compatibility issues with the timespec struct (diff)
downloadgentoo-1345d000.tar.gz
gentoo-1345d000.tar.bz2
gentoo-1345d000.zip
net-fs/samba: Minor ebuilds improvements.
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-fs/samba/samba-4.9.2-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-fs/samba/samba-4.9.2-r1.ebuild b/net-fs/samba/samba-4.9.2-r1.ebuild
index 9552e026df24..6ce5625ef29b 100644
--- a/net-fs/samba/samba-4.9.2-r1.ebuild
+++ b/net-fs/samba/samba-4.9.2-r1.ebuild
@@ -158,7 +158,9 @@ src_prepare() {
sed -i -e '/"dns.resolver":/d' "${S}"/third_party/wscript || die
# unbundle iso8601 unless tests are enabled
- use test || sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+ if ! use test ; then
+ sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+ fi
# ugly hackaround for bug #592502
cp /usr/include/tevent_internal.h "${S}"/lib/tevent/ || die
@@ -231,7 +233,7 @@ multilib_src_install() {
waf-utils_src_install
# Make all .so files executable
- find "${ED}" -type f -name "*.so" -exec chmod +x {} +
+ find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
if multilib_is_native_abi ; then
# install ldap schema for server (bug #491002)