summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-03 17:31:03 +0000
committerSam James <sam@gentoo.org>2023-02-03 17:47:53 +0000
commit1352a480e30e215bfcea3f08e9af4d3079dbebe9 (patch)
tree5496a58786163119dc086c298defcd7206d6a59d
parentdev-util/cmake: drop 3.23.3, 3.25.1 (diff)
downloadgentoo-1352a480e30e215bfcea3f08e9af4d3079dbebe9.tar.gz
gentoo-1352a480e30e215bfcea3f08e9af4d3079dbebe9.tar.bz2
gentoo-1352a480e30e215bfcea3f08e9af4d3079dbebe9.zip
net-dns/bind-tools: depend on newer libuv
At https://gitlab.isc.org/isc-projects/bind9/-/blob/v9_16/lib/isc/netmgr/netmgr.c#L244, there's a check for runtime version vs built against version, but not equality, just whether it's new enough if at build time, we built against something which had more features b/c newer. Require the newest one in the list to avoid issues when mixing stable/~arch and also because we're not going to be testing an old libuv anyway. Reported by robbat2. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.33-r1.ebuild (renamed from net-dns/bind-tools/bind-tools-9.16.33.ebuild)7
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.36-r1.ebuild (renamed from net-dns/bind-tools/bind-tools-9.16.36.ebuild)5
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.37-r1.ebuild (renamed from net-dns/bind-tools/bind-tools-9.16.37.ebuild)5
3 files changed, 13 insertions, 4 deletions
diff --git a/net-dns/bind-tools/bind-tools-9.16.33.ebuild b/net-dns/bind-tools/bind-tools-9.16.33-r1.ebuild
index 9fac2b5c984e..a0e03ab0062c 100644
--- a/net-dns/bind-tools/bind-tools-9.16.33.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.33-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,8 +21,11 @@ IUSE="+caps doc gssapi idn libedit readline test xml"
# no PKCS11 currently as it requires OpenSSL to be patched, also see bug #409687
RESTRICT="!test? ( test )"
+# libuv lower bound should be the highest value seen at
+# https://gitlab.isc.org/isc-projects/bind9/-/blob/v9_16/lib/isc/netmgr/netmgr.c#L244
+# to avoid issues with matching stable/testing, etc
COMMON_DEPEND="
- dev-libs/libuv:=
+ >=dev-libs/libuv-1.42.0:=
dev-libs/openssl:=
caps? ( sys-libs/libcap )
xml? ( dev-libs/libxml2 )
diff --git a/net-dns/bind-tools/bind-tools-9.16.36.ebuild b/net-dns/bind-tools/bind-tools-9.16.36-r1.ebuild
index 4e991c95960e..632173751156 100644
--- a/net-dns/bind-tools/bind-tools-9.16.36.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.36-r1.ebuild
@@ -21,8 +21,11 @@ IUSE="+caps doc gssapi idn libedit readline test xml"
# no PKCS11 currently as it requires OpenSSL to be patched, also see bug #409687
RESTRICT="!test? ( test )"
+# libuv lower bound should be the highest value seen at
+# https://gitlab.isc.org/isc-projects/bind9/-/blob/v9_16/lib/isc/netmgr/netmgr.c#L244
+# to avoid issues with matching stable/testing, etc
COMMON_DEPEND="
- dev-libs/libuv:=
+ >=dev-libs/libuv-1.42.0:=
dev-libs/openssl:=
caps? ( sys-libs/libcap )
xml? ( dev-libs/libxml2 )
diff --git a/net-dns/bind-tools/bind-tools-9.16.37.ebuild b/net-dns/bind-tools/bind-tools-9.16.37-r1.ebuild
index 8c70c6e06ed8..da4c92eb0df6 100644
--- a/net-dns/bind-tools/bind-tools-9.16.37.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.37-r1.ebuild
@@ -21,8 +21,11 @@ IUSE="+caps doc gssapi idn libedit readline test xml"
# no PKCS11 currently as it requires OpenSSL to be patched, also see bug #409687
RESTRICT="!test? ( test )"
+# libuv lower bound should be the highest value seen at
+# https://gitlab.isc.org/isc-projects/bind9/-/blob/v9_16/lib/isc/netmgr/netmgr.c#L244
+# to avoid issues with matching stable/testing, etc
COMMON_DEPEND="
- dev-libs/libuv:=
+ >=dev-libs/libuv-1.42.0:=
dev-libs/openssl:=
caps? ( sys-libs/libcap )
xml? ( dev-libs/libxml2 )