summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-30 07:47:12 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-30 07:47:46 +0100
commit135d88401a60dbbc0905c1f16391cea46b8d0cc0 (patch)
tree97f323a32e054a12ab8df782551e7ec574ad4e9c
parentx11-drivers/nvidia-drivers: add 470.62.28:0/vulkan, drop 470.62.26 (diff)
downloadgentoo-135d88401a60dbbc0905c1f16391cea46b8d0cc0.tar.gz
gentoo-135d88401a60dbbc0905c1f16391cea46b8d0cc0.tar.bz2
gentoo-135d88401a60dbbc0905c1f16391cea46b8d0cc0.zip
sys-devel/mold: don't invoke python during build
Closes: https://bugs.gentoo.org/841575 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--sys-devel/mold/files/mold-1.2.1-install-nopython.patch34
-rw-r--r--sys-devel/mold/mold-1.2.1-r1.ebuild (renamed from sys-devel/mold/mold-1.2.1.ebuild)5
-rw-r--r--sys-devel/mold/mold-9999.ebuild5
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-1.2.1-install-nopython.patch b/sys-devel/mold/files/mold-1.2.1-install-nopython.patch
new file mode 100644
index 000000000000..661d3dcf392f
--- /dev/null
+++ b/sys-devel/mold/files/mold-1.2.1-install-nopython.patch
@@ -0,0 +1,34 @@
+From 4fb6d4208cfb20bad4a3491a18e78409b5a8183f Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Sat, 30 Apr 2022 07:42:50 +0100
+Subject: [PATCH] Don't invoke Python to create libexec/mold/ld symlink
+
+Reverts commits 8073a92614fb59f59570031badab5dd4bc3b4f7f and
+5803c3c200f301adc3abdb66df16d3d669712d70.
+
+Bug #841575
+---
+ Makefile | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d1abc850..10e053a9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -204,12 +204,7 @@ install: all
+ $(STRIP) $D$(LIBDIR)/mold/mold-wrapper.so
+
+ $(INSTALL) -d $D$(LIBEXECDIR)/mold
+-
+-# We want to make a symblink with a relative path, so that users can
+-# move the entire directory to other place without breaking the reference.
+-# GNU ln supports `--relative` to do that, but that's not supported by
+-# non-GNU systems. So we use Python to compute a relative path.
+- ln -sf `python3 -c "import os.path; print(os.path.relpath('$(BINDIR)/mold', '$(LIBEXECDIR)/mold'))"` $D$(LIBEXECDIR)/mold/ld
++ ln -sf $(BINDIR)/mold $D$(LIBEXECDIR)/mold/ld
+
+ $(INSTALL) -d $D$(MANDIR)/man1
+ $(INSTALL_DATA) docs/mold.1 $D$(MANDIR)/man1
+--
+2.35.3
+
diff --git a/sys-devel/mold/mold-1.2.1.ebuild b/sys-devel/mold/mold-1.2.1-r1.ebuild
index a9e0aa6a2c2e..87931221e192 100644
--- a/sys-devel/mold/mold-1.2.1.ebuild
+++ b/sys-devel/mold/mold-1.2.1-r1.ebuild
@@ -28,6 +28,11 @@ RDEPEND=">=dev-cpp/tbb-2021.4.0:=
# TODO: restore SYSTEM_XXHASH upstream?
DEPEND="${RDEPEND}"
+PATCHES=(
+ # Bug #841575
+ "${FILESDIR}"/${PN}-1.2.1-install-nopython.patch
+)
+
pkg_pretend() {
# Requires a c++20 compiler, see #831473
if [[ ${MERGE_TYPE} != binary ]]; then
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index a9e0aa6a2c2e..87931221e192 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -28,6 +28,11 @@ RDEPEND=">=dev-cpp/tbb-2021.4.0:=
# TODO: restore SYSTEM_XXHASH upstream?
DEPEND="${RDEPEND}"
+PATCHES=(
+ # Bug #841575
+ "${FILESDIR}"/${PN}-1.2.1-install-nopython.patch
+)
+
pkg_pretend() {
# Requires a c++20 compiler, see #831473
if [[ ${MERGE_TYPE} != binary ]]; then