summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-29 17:46:48 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-29 17:55:56 -0400
commit136280ce1ab9c5c3bfcca36c27118f481e99871d (patch)
treee185a569a8b09539e676799d6fb92b6927e7d8eb
parentapp-emulation/diskimage-builder: 3.22.0 bump (diff)
downloadgentoo-136280ce.tar.gz
gentoo-136280ce.tar.bz2
gentoo-136280ce.zip
net-libs/glib-networking: Version bump to 2.72.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.72.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 057a44158cd8..b1b39ce8d788 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1 +1,2 @@
DIST glib-networking-2.72.0.tar.xz 265060 BLAKE2B 2ffb25b059db40fcf9b65b104cd50d81dda9482bc75031d62c10f70eaaa2e9fcfcdfb2b718253255a2565d7b6bc9ead2214167d1b5f482c0ddd3af8573dd2ef5 SHA512 2b42aebcf496f51604005f6f3243ed7e613ab3d485742b7d8af10e103b07eefd8931cc86c1cb021889fe1415ad98bf4d877a3f33203cb53688cc2c41373a8ce4
+DIST glib-networking-2.72.1.tar.xz 265308 BLAKE2B 84264df5e094a4c57d86edd57fdedb11ad00eec5937eb056de34ec3d38a0e0e2ec3d71a5ad4ab0386c45681c8784b792ca6ded9c048d93c3ed1ad47d2f31f44e SHA512 243f54f4fbce40211f276c4f56e4e40507ecb0b23527a04b2d5bd67185c017f736f088c71ebf225e69e1ae8efa5b835edd68ea5c96df3ff69a25fd391e5c52d0
diff --git a/net-libs/glib-networking/glib-networking-2.72.1.ebuild b/net-libs/glib-networking/glib-networking-2.72.1.ebuild
new file mode 100644
index 000000000000..f5cb25001455
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.72.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.69.0:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.2:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tests')/d" tls/meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}