summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-04 22:22:14 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-04 22:22:51 +0200
commit1363da5b9c01e1c348fccd21f1b81dabd326db50 (patch)
tree51ddb6d1aca9b923970a2f003ec0146cfe8b40bb
parentdev-lang/ruby: put back darwin gcc buildfix for 3+ (diff)
downloadgentoo-1363da5b9c01e1c348fccd21f1b81dabd326db50.tar.gz
gentoo-1363da5b9c01e1c348fccd21f1b81dabd326db50.tar.bz2
gentoo-1363da5b9c01e1c348fccd21f1b81dabd326db50.zip
dev-python/django-debug-toolbar: add test
Closes: https://bugs.gentoo.org/905354 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild
index 8937c1b48d37..a3cbe8809461 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild
@@ -15,6 +15,10 @@ SRC_URI="https://github.com/jazzband/${PN}/archive/refs/tags/${PV}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RESTRICT="test" # Need some effort to do that
RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}