summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-01 23:31:26 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-01 23:33:04 +0100
commit1372e7842d39c2293a028df4435afc2f45030220 (patch)
tree231c38c842858f706c39be6da983a39623f5a894
parentprofiles: Un-last-rite games-arcade/ceferino (diff)
downloadgentoo-1372e784.tar.gz
gentoo-1372e784.tar.bz2
gentoo-1372e784.zip
www-apps/grafana-bin: bump to v7.3.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-apps/grafana-bin/Manifest1
-rw-r--r--www-apps/grafana-bin/grafana-bin-7.3.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/www-apps/grafana-bin/Manifest b/www-apps/grafana-bin/Manifest
index 81074b6fa93d..a4459accac3d 100644
--- a/www-apps/grafana-bin/Manifest
+++ b/www-apps/grafana-bin/Manifest
@@ -1,2 +1,3 @@
DIST grafana-bin-6.7.4.tar.gz 65083442 BLAKE2B c619432325ac5254c78ec08579f048483dfd1b28fbf8a9b919517277ad887b238f953ba796366af5c9f29a53daeade160c55a2255cfe75bf767b4ddd57474f87 SHA512 fe412966558529f114b70a5cb42f82c37dce67b2b04739ddba0d9821a3e12a5f1e44757df19d283a9b486737a411ca759adab9beaca6d0f14259945675218df4
DIST grafana-bin-7.1.3.tar.gz 52611015 BLAKE2B 15f66a1cbe1669df4ae6b14347c4a7df8825780b9f01c090e3facea6ebbc375a79d25a50c8047a91c96d3d0f3c05800159dc40c9d4df3a6c9e7405a006ee6c11 SHA512 556211cd2d32068c0f6be6ea8c88144dc2d7c3577c2ab8661cc4f4d330a7c62df7fc98e3d222a7693d1b1d92207af694514faa1c3c2d5507780fdba731bd0bf8
+DIST grafana-bin-7.3.1.tar.gz 53950606 BLAKE2B 16e0253371cb267876772e788e00d2330c664e3f0fea7f3891dbf5d4300e0baf99dd626ac2801201fda87f967d0013a151c672b341179e355acd43430f51acaa SHA512 0436b5bec58e52582542bb1efe7825ffc7abd5289d82916c6a54c6aee77a7350060ef877734b32332a5f3935cf1a3404b670e5f9344a8bb9b5c91d95ad81e214
diff --git a/www-apps/grafana-bin/grafana-bin-7.3.1.ebuild b/www-apps/grafana-bin/grafana-bin-7.3.1.ebuild
new file mode 100644
index 000000000000..d666b4c9db30
--- /dev/null
+++ b/www-apps/grafana-bin/grafana-bin-7.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+MY_PN=${PN/-bin/}
+MY_PV=${PV/_beta/-beta}
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+DESCRIPTION="Gorgeous metric viz, dashboards & editors for Graphite, InfluxDB & OpenTSDB"
+HOMEPAGE="https://grafana.org"
+SRC_URI="https://dl.grafana.com/oss/release/grafana-${PV}.linux-amd64.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="acct-group/grafana
+ acct-user/grafana"
+RDEPEND="${DEPEND}
+ media-libs/fontconfig"
+
+QA_PREBUILT="usr/bin/grafana-*"
+QA_PRESTRIPPED=${QA_PREBUILT}
+
+src_install() {
+ keepdir /etc/grafana
+ insinto /etc/grafana
+ newins "${S}"/conf/sample.ini grafana.ini
+ rm "${S}"/conf/sample.ini || die
+
+ # Frontend assets
+ insinto /usr/share/${MY_PN}
+ doins -r public conf
+
+ dobin bin/grafana-cli
+ dobin bin/grafana-server
+
+ newconfd "${FILESDIR}"/grafana.confd grafana
+ newinitd "${FILESDIR}"/grafana.initd.3 grafana
+ systemd_newunit "${FILESDIR}"/grafana.service grafana.service
+
+ keepdir /var/{lib,log}/grafana
+ keepdir /var/lib/grafana/{dashboards,plugins}
+ fowners grafana:grafana /var/{lib,log}/grafana
+ fowners grafana:grafana /var/lib/grafana/{dashboards,plugins}
+ fperms 0750 /var/{lib,log}/grafana
+ fperms 0750 /var/lib/grafana/{dashboards,plugins}
+}
+
+postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ elog "${PN} has built-in log rotation. Please see [log.file] section of"
+ elog "/etc/grafana/grafana.ini for related settings."
+ elog
+ elog "You may add your own custom configuration for app-admin/logrotate if you"
+ elog "wish to use external rotation of logs. In this case, you also need to make"
+ elog "sure the built-in rotation is turned off."
+ fi
+}