summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 12:17:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 13:41:03 +0100
commit1397eece4183adbe5cbdeb51a449f8d82272ecd2 (patch)
tree2bc3a5e871b9f595919e4c9c89d87c0d5bf7bf10
parentdev-python/sarif_om: New dep of cfn-lint, v1.0.4 (diff)
downloadgentoo-1397eece4183adbe5cbdeb51a449f8d82272ecd2.tar.gz
gentoo-1397eece4183adbe5cbdeb51a449f8d82272ecd2.tar.bz2
gentoo-1397eece4183adbe5cbdeb51a449f8d82272ecd2.zip
dev-python/cfn-lint: Bump to 0.56.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.56.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 2ef7cc40e552..9b2e7485c9f3 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-lint-0.54.3.tar.gz 7806470 BLAKE2B b61cb4b46e7c9d04aa70d2542e2aee0d029cc265ca3b85d9bd1c9ddcf2d22a56b28d74f27d6ccf5348cef7224e1ca9d1efec3e5a7b478e8bb87afcb0d39b3da8 SHA512 40e593f0bf092dafca7d7a801deaf2e09c37f4421d58b9244a2da533c3079da076dab70cb974868fd3eb9300ef69897414b03854f8e8fee139e1f5b4781795fc
DIST cfn-lint-0.54.4.tar.gz 7835716 BLAKE2B 1709adda09a08b02f4a2637af1ed2a43c096d8f9eef91b3cfbac55365e0910be64c632e28e403356742396b72a4af6c88740b27d13a67b62b5f5af98c8639e43 SHA512 f31b8fc407adf75b1eb54a29719b39298494efcdba65e68610e28ca1d066dfdb3fa051e8a90fe589793683c01e49d1bab30832255153e8932bd9caca96b54441
+DIST cfn-lint-0.56.0.tar.gz 8069291 BLAKE2B 6a6b0481f857e3360d2abeb372415a43ae59ed54f2c1ef08ea079f32442bea9f30a7222233cfadd398922994bc70aa78e92b8807d7386ca4b979548622d3e5f4 SHA512 f12ca4ba831c32d7c9c8079ed9d59baf6346a2c4a09cf2af0a8b258dc551b381983cb346800b37e6df3022fbb6f09ee186b44bb9ba3e0a2713c8faabce83f67b
diff --git a/dev-python/cfn-lint/cfn-lint-0.56.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.56.0.ebuild
new file mode 100644
index 000000000000..8b9a92699ebe
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.56.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.40.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}