summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-08 21:53:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-08 22:17:52 +0300
commit139b0339697de6c7639ec3a39fd1d8bd1560dbac (patch)
treec7ada5ea571d1efd378c71c4392282bdfd4ac91b
parentdev-python/nuitka: add 1.0.2 (diff)
downloadgentoo-139b0339.tar.gz
gentoo-139b0339.tar.bz2
gentoo-139b0339.zip
dev-python/nuitka: drop 0.9.5, 0.9.6, 1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest3
-rw-r--r--dev-python/nuitka/nuitka-0.9.5.ebuild49
-rw-r--r--dev-python/nuitka/nuitka-0.9.6.ebuild49
-rw-r--r--dev-python/nuitka/nuitka-1.0.ebuild49
4 files changed, 0 insertions, 150 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 05c44b924b87..a2e7708d4099 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,5 +1,2 @@
-DIST Nuitka-0.9.5.tar.gz 3858378 BLAKE2B 0b8aa2b191caaa348fda81af41d7a4ad486479742acb929c6e0f0c1ec08b06ca02c5cae46b986c569a8bb792e15fbb90e49db9ece3b226d4e09c054b4311f079 SHA512 4e0def27cc12f4b37debb509c015ba9e56649e82ecede31c142b7c420424364fb243932bd146397bfb82aea1591a06566b346a1b2c6d64cf26cdc59eb77cf875
-DIST Nuitka-0.9.6.tar.gz 3858273 BLAKE2B 5fbe454c5f5612d94342b1247b463a4248a35123d7d4515dadb4c9f4cf5b6714f55e1972d55f60cfdfe65ca97af5fae2cfc92009b274ccf9adaf944217a39333 SHA512 6088459a12f5506a547d40a4c3f0f16f8ab470ee4875d36dfad97e4ba25d7cdc25cae1115a11dd7752dafe51d6c83d80798c74a110c995e47ba127d9b2afbf81
DIST Nuitka-1.0.1.tar.gz 3893766 BLAKE2B 7d48344231fca1efce8d783a197813a1aa77c992fad84c1a958740287ea8079566c98bb6ac1e017030a6d6dba84bdef6a7711542adaa8a59612aed19da96f425 SHA512 0d3ba38733fdee4f6f4bff80fd2c7729177209e101f0eefe2c5a74fd449d038710eb979e1b313c1534bfe079ea3a7f88cda07ba2977c153032a56db0b75f739c
DIST Nuitka-1.0.2.tar.gz 3893195 BLAKE2B 7d3f154ecb128da34f1495d977ec81bc54dcd95d5d53d3ef437a0a55f11f91529eb12c985eba6256d53d2746e0b2925a50ab4fd19967f602c552a57c1ec51408 SHA512 a1cd4ba3b2ced48fd2b8fdd2438f8b6108ce3638fb59507bd2398cc8d3e9c9eb9b93d86446e960d26df351c2769799df3a8ca248482eee531dd6bbc276036a90
-DIST Nuitka-1.0.tar.gz 3892664 BLAKE2B 6772c4af5a4fcee704a0c9b14b25a5ae8ca0d5663f2a60791dd194ae402dc0dccad1fbc3b85089469090f2f10cb0641fe739ef3f1c8c236292ac7e468c0de27d SHA512 4b8d17e49da152ab7c0ad146296375e8f8566bbd730ceac158c8dc9ed1588509384627f538dec347774b890a4715b4ba054b3be66b1b425bb736d35752b5db58
diff --git a/dev-python/nuitka/nuitka-0.9.5.ebuild b/dev-python/nuitka/nuitka-0.9.5.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-0.9.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/nuitka/nuitka-0.9.6.ebuild b/dev-python/nuitka/nuitka-0.9.6.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-0.9.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/nuitka/nuitka-1.0.ebuild b/dev-python/nuitka/nuitka-1.0.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}