summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 09:14:27 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-15 09:59:57 +0100
commit13c2e05983b431fb67b63457b3f4dd22c4d414f2 (patch)
tree9568f6a8e5d2e9aec9493e6f99a55e811d7f6b7e
parentdev-python/hypothesis: Bump to 4.44.2 (diff)
downloadgentoo-13c2e05983b431fb67b63457b3f4dd22c4d414f2.tar.gz
gentoo-13c2e05983b431fb67b63457b3f4dd22c4d414f2.tar.bz2
gentoo-13c2e05983b431fb67b63457b3f4dd22c4d414f2.zip
dev-python/setuptools: Remove 36.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-36.7.2.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 9a3616dbd7a7..ab19958afeca 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,4 +1,3 @@
-DIST setuptools-36.7.2.zip 726758 BLAKE2B 8821d3142f2149fbdea4d231052c3990fa7a14c57c421309683c6a65102ce4911850acd5d492087aa0f14a0026da732e47eb9bf971030443fc1b57f9f909aaaa SHA512 746dce135dbacb65565787a20a2611388605e2371c94f0f8803e7712e515e69c270751d16a21f381bf6e8ddc0a1b39494db7d0c67bb32e6230a90c5d517e78f9
DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31d670bddb9e4ea058b8ee7dffbe6fcb0e5fd24baf3fb38f5e824fde36aa8dc1e09d7ac37f9375ee351406389cd6 SHA512 6c628b8fc67645bca96ddcd016ec9a685e91690bf98dff077e842cfbd0d8d24de76ac51b3ff238d31551a48819d8f694fee6e9bb422ca954e54c22b4bda0038c
DIST setuptools-41.1.0.zip 851100 BLAKE2B 1a2dcb1d3f1a34d9a5dab5156b76cddb03da0f3745e57ebdd363cdd23512df0de8f0d3131c930e2b67ae34fc15f75a9c06802826f97508bfb937a9e45ff287f4 SHA512 07e3381fffc7b75051640c07e334794cb008682e05ab8bbd5bb1e9757fd36305997a2974c424fd474411941f5ff014a53ec1edc276543593b238fe1e97d7d106
DIST setuptools-41.2.0.zip 851251 BLAKE2B 1c4896c429c670832a46f951dc4c4958f808f1a7c0ad88670705fe265bee23c1d2b6a348b13298b0a60b6c821d504567d4d35b33f388949028391219cd45191e SHA512 6ac0da9f2e452b2b2334c03eb1667d88ebffeb68da18a69fe14f9f0763ac391986dcc663f123015b63eb0c3f905e5a8be7408499ddb1ac20367109275cb66ac9
diff --git a/dev-python/setuptools/setuptools-36.7.2.ebuild b/dev-python/setuptools/setuptools-36.7.2.ebuild
deleted file mode 100644
index 4700480c42a2..000000000000
--- a/dev-python/setuptools/setuptools-36.7.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy{,3} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Collection of extensions to Distutils"
-HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
- dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-PDEPEND="
- >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
-
-# Force in-source build because build system modifies sources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
-
-python_prepare_all() {
- if [[ ${PV} == "9999" ]]; then
- python_setup
- ${EPYTHON} bootstrap.py || die
- fi
-
- # disable tests requiring a network connection
- rm setuptools/tests/test_packageindex.py || die
-
- # don't run integration tests
- rm setuptools/tests/test_integration.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
- # It tries to sandbox the test in a tempdir
- HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
- distutils-r1_python_install
-}