summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-27 20:12:11 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-27 22:49:47 +0200
commit13d09be7a931f44a19e32988e7fd7dcbd28ec232 (patch)
treee71ace2ce65f8267a6abfe82808658580e42ce6e
parentdev-python/MechanicalSoup: fix DESCRIPTION, update metadata (diff)
downloadgentoo-13d09be7.tar.gz
gentoo-13d09be7.tar.bz2
gentoo-13d09be7.zip
dev-python/MechanicalSoup: bump to 0.10.0, ~x86+doc+examples
Also fix dependencies and add PyPy. Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
index d51a2b62c2ff..ebaa6abdf568 100644
--- a/dev-python/MechanicalSoup/Manifest
+++ b/dev-python/MechanicalSoup/Manifest
@@ -1 +1,2 @@
+DIST MechanicalSoup-0.10.0.tar.gz 40111 BLAKE2B cbb09253666850d3ce433f60ed6405585588e6dc7198c58de1cab8ecfad1e1c814433787aefe33dbb490edab5367ffca285d14cf8fbcb2c16e309b957a3a311b SHA512 5fa493abac39c5084dacb67b9dfaa2f8f5af773d3e3aaff48e6240596e863ada30a2fd1e345188c3249fd6e570977aa45b9fd553fe5a549f8430f170613bb866
DIST MechanicalSoup-0.6.0.zip 5286 BLAKE2B 93a1d124cd45820e425fcb50b2aec04026f7a6f42c7c3f5c93103fbd216c98e36f366a1f7f343dd5561688ac4adb6feacab08ae444f91156348c07a80710a306 SHA512 cc413723514f3beee1267c57c16f6de2c19eb1f64535a60b546d289c7c18d8c4ba752ea61ab0b4a2aead2b56b12639cd226cb32662622515cb40262b7e619c24
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild
new file mode 100644
index 000000000000..808ae3326860
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library for automating interaction with websites"
+HOMEPAGE="https://pypi.org/project/MechanicalSoup/"
+# https://github.com/MechanicalSoup/MechanicalSoup/pull/217
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+# https://github.com/MechanicalSoup/MechanicalSoup/issues/215
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip coverage and flake8
+ py.test --override-ini="addopts=" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}