summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2024-05-14 14:10:20 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2024-05-14 14:10:51 +0200
commit13d8c73c84bc53710327233de6d1d03f05fd1140 (patch)
tree7da5fb47f4d925be9df12f4374fe9b3f4f77f005
parentdev-python/requests: Enable py3.13 (diff)
downloadgentoo-13d8c73c84bc53710327233de6d1d03f05fd1140.tar.gz
gentoo-13d8c73c84bc53710327233de6d1d03f05fd1140.tar.bz2
gentoo-13d8c73c84bc53710327233de6d1d03f05fd1140.zip
net-dns/dnsdist: add 1.9.4
Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
-rw-r--r--net-dns/dnsdist/Manifest1
-rw-r--r--net-dns/dnsdist/dnsdist-1.9.4.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index 99501f134796..54da945169db 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -2,3 +2,4 @@ DIST dnsdist-1.8.0.tar.bz2 1480500 BLAKE2B 47cfcfe3756cdc4520c1ba1e11b7d60191125
DIST dnsdist-1.8.1.tar.bz2 1492793 BLAKE2B 84fdf2f360c41ea235f3989d2bc14ad05e98d7b51dd20d983e7ad53ce5a6c00c7075b673e8a15fe3fd710a4e15c80db4d7431256bfb4291bd5785482d3f7f7e5 SHA512 db50c56587084ebdea3eb7f8e5b79178aea67b608cf6afce1453932b5225b3474a459cdc3dc8e4618a36a9edb405403dfefaed7fadd5848b5612de6bfb356f3a
DIST dnsdist-1.9.0.tar.bz2 1620891 BLAKE2B 9e14f275d83429ab3e83bdbbd6fe8d97b3212763398798d704adcc18d07ad8aebe16c5345425cdb589f6166155717d9649c16546bf981eb265e1349e74d11134 SHA512 32c0b9b3a1b58839da6dbde05eee382b78fbe58d68aed14f4927dc172dfcb15ba68b6d2246a8305b709e136e0e0c8666b6dd139ac258c8209083ff3b5673b997
DIST dnsdist-1.9.3.tar.bz2 1577027 BLAKE2B 663b8a2161c5a7b94541cd775f135a99997024648c5bb57fd2ec18c7ede29aebda142452f97332300c45af32b5131e4dd5f9c1f904a1d68962398fa9a28c474e SHA512 26b4fa70c1ad70e21d86cc51389bffacbfecedd769e2bb39f376d1dc85491c9eddbd1aea1e4a9bd08d05fc58c2f1fc906d1ff19c8dfd653a779f4171242a546f
+DIST dnsdist-1.9.4.tar.bz2 1591994 BLAKE2B a8cfc5c2da135ed96b857f9f1b6c3caa796b27f66ff7ead6e976b871a5e5db208ef3ce275c23085318bd7ff2f0fa2ec19e28ad36234991d84b8d13e74acb2f34 SHA512 e013fa3e582cc30d104a66ee44eec50dd1d04cb2bd0dc5b3c9dfec95f3e0e5f3da5f2a1bb9a713b50e5659908669957fe4deb5b1ca10f728e6ceaf550a3223ef
diff --git a/net-dns/dnsdist/dnsdist-1.9.4.ebuild b/net-dns/dnsdist/dnsdist-1.9.4.ebuild
new file mode 100644
index 000000000000..33366646a868
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.9.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="bpf cdb dnscrypt dnstap doh doh3 ipcipher lmdb quic regex snmp +ssl systemd test web xdp"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnscrypt? ( ssl )
+ doh? ( ssl )
+ doh3? ( ssl quic )
+ ipcipher? ( ssl )
+ quic? ( ssl )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ bpf? ( dev-libs/libbpf:= )
+ cdb? ( dev-db/tinycdb:= )
+ dev-libs/boost:=
+ sys-libs/libcap
+ dev-libs/libedit
+ dev-libs/libsodium:=
+ dnstap? ( dev-libs/fstrm )
+ doh? ( net-libs/nghttp2:= )
+ doh3? ( net-libs/quiche:= )
+ lmdb? ( dev-db/lmdb:= )
+ quic? ( net-libs/quiche )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:0= )
+ xdp? ( net-libs/xdp-tools )
+ ${LUA_DEPS}
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # clean up duplicate file
+ rm -f README.md
+}
+
+src_configure() {
+ # bug #822855
+ append-lfs-flags
+
+ # some things can only be enabled/disabled by defines
+ ! use dnstap && append-cppflags -DDISABLE_PROTOBUF
+ ! use web && append-cppflags -DDISABLE_BUILTIN_HTML
+
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+
+ local myeconfargs=(
+ --sysconfdir=/etc/dnsdist
+ --with-lua="${ELUA}"
+ --without-h2o
+ --enable-tls-providers
+ --without-gnutls
+ $(use_with bpf ebpf)
+ $(use_with cdb cdb)
+ $(use_enable doh dns-over-https)
+ $(use_enable doh3 dns-over-http3)
+ $(use_enable dnscrypt)
+ $(use_enable dnstap)
+ $(use_enable ipcipher)
+ $(use_with lmdb )
+ $(use_enable quic dns-over-quic)
+ $(use_with regex re2)
+ $(use_with snmp net-snmp)
+ $(use_enable ssl dns-over-tls)
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ $(use_with xdp xsk)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}