summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-02 18:55:37 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-02 18:56:03 -0500
commit13e46a3e788b77e726ad0cc8883b4ee3f39cf2e5 (patch)
treec2f1e96a8474f5c7b904ba548908a148e92883b7
parentapp-crypt/gpgme: remove unused patch (diff)
downloadgentoo-13e46a3e788b77e726ad0cc8883b4ee3f39cf2e5.tar.gz
gentoo-13e46a3e788b77e726ad0cc8883b4ee3f39cf2e5.tar.bz2
gentoo-13e46a3e788b77e726ad0cc8883b4ee3f39cf2e5.zip
app-backup/spideroak-bin: version bump to 7.0.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-7.0.0.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index 3fe264deabb9..7df48336e8ed 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -2,3 +2,5 @@ DIST spideroak-bin-6.3.0_amd64.deb 26882606 BLAKE2B 0113ddf19be6aaaf78bde3574e78
DIST spideroak-bin-6.3.0_x86.deb 26402134 BLAKE2B 2c515b4601400e0a0dbce5c92f96294643f60590703c5101b207adb5021567f91325a06c08d3b11fc248d5493f76d5f1398417db303acd9cb4f875b3c4accfd1 SHA512 3945d671f0dff0e193bf0cd951d2380f50f28921ab3166d26cebf2564caef03e46967c0032b2da02b012ab4c71332af869d117e0ac7c5dfde99dc1e9d9399d5e
DIST spideroak-bin-6.4.0_amd64.deb 26882606 BLAKE2B 0113ddf19be6aaaf78bde3574e7832af53d774eec6783b91cf72e74babe4b159ce9a61365d92358f8b5afb063d05e86ee75ea6bfc9fac0e34b195d42890e7b3f SHA512 23283574955833199cc86be9eec3781c190da8a0885c31b20bfb7f73976c8e3663c76571ddf5f2c9e9d2377d71121f605ce7698788704b482dbce8290e77a7e2
DIST spideroak-bin-6.4.0_x86.deb 26402134 BLAKE2B 2c515b4601400e0a0dbce5c92f96294643f60590703c5101b207adb5021567f91325a06c08d3b11fc248d5493f76d5f1398417db303acd9cb4f875b3c4accfd1 SHA512 3945d671f0dff0e193bf0cd951d2380f50f28921ab3166d26cebf2564caef03e46967c0032b2da02b012ab4c71332af869d117e0ac7c5dfde99dc1e9d9399d5e
+DIST spideroak-bin-7.0.0_amd64.deb 25663732 BLAKE2B fd91517a6722e1648c08e2885a2659df976db86912f68e024858865a8a319759e5399a107925880b51c293251f55be45360f6f0235c357b6a74b4b50e55daf2d SHA512 a7bc9bb3b7dbaeef43146c2e0f6d0fe690e3710a28d0b2f753f701675dada2fbb449bf95d0cae289ea4b03aae8f39b916efbb2da531d7cdab5d6df85b481609f
+DIST spideroak-bin-7.0.0_x86.deb 25174384 BLAKE2B 85642257033706b6253af6c890493cfe2be652bf062a882a9a4546089df20f1f5a0618ee7bd573c68a8fd0da39f1f06effbe667656e23db3148151d6d500d0db SHA512 01d86b04dfd7d57ef5e64494c7f2f38fd9ef0e7a215937a2b8c4be4f0e5faacdfbf0d6cd965120ff0ddfdf08b7394e7bbd5074f4d1186795969e409f8c9df7bd
diff --git a/app-backup/spideroak-bin/spideroak-bin-7.0.0.ebuild b/app-backup/spideroak-bin/spideroak-bin-7.0.0.ebuild
new file mode 100644
index 000000000000..b50355c676a7
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-7.0.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils unpacker
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+
+SRC_URI_BASE="https://spideroak.com/release/spideroak"
+SRC_URI="x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )"
+
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ media-libs/libpng:1.2
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ #Remove the libraries that break compatibility in modern systems
+ #SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+
+ eapply_user
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}