summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-25 08:55:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-25 10:41:27 +0200
commit13eb84ad4527eb76abeb19745499cc0280620f5d (patch)
tree8768d7417104ea9070c7da040a1cce9121030ac3
parentdev-python/grpcio-testing: Remove old (diff)
downloadgentoo-13eb84ad.tar.gz
gentoo-13eb84ad.tar.bz2
gentoo-13eb84ad.zip
dev-python/grpcio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/files/1.37.1-cxx-no-gnu99.patch35
-rw-r--r--dev-python/grpcio/grpcio-1.37.1-r1.ebuild50
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 982c9eebc3fd..4da9bd27415e 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,2 +1 @@
-DIST grpcio-1.37.1.tar.gz 21678919 BLAKE2B ea1c9a1ce1d888d0e9aca27a9e12ebcaca5c79b6f70a282e4e9a12a4aba982c2cef3f755cc2e789de2302071ce3abf12c91f329febd04159b3c8abded96818d5 SHA512 e7697a6d0da40b7d63be7f4f31223d2314bf16fcab8887a41bc4750c844a58ad55fd27fca0a9f1016fc725076a16c3b2db5a9eb040a86a2acb9f45083835d90e
DIST grpcio-1.38.1.tar.gz 21392075 BLAKE2B 92f1ad9e119fe346bc1f8f10ffe7067fb736c975ecd276eb8ab37a3b25d0a818fff76cec164db5745ac157ba7b94b841c6e66bb332d9f3b2c08974cab415a973 SHA512 c4f831ee654eec78f01c099fa5a6d9dc7e9551b1db5e5c89e3b8bd4e5c3bae622aee32cac9212bb60bc1baec98e4a49f8e18c0043bc90d1144729dee337072f9
diff --git a/dev-python/grpcio/files/1.37.1-cxx-no-gnu99.patch b/dev-python/grpcio/files/1.37.1-cxx-no-gnu99.patch
deleted file mode 100644
index 71e02eafeb65..000000000000
--- a/dev-python/grpcio/files/1.37.1-cxx-no-gnu99.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 05ae3c5a87ba1037bd4c7a94e6b574c8df847065 Mon Sep 17 00:00:00 2001
-From: Lidi Zheng <lidiz@google.com>
-Date: Tue, 6 Apr 2021 06:50:40 -0700
-Subject: [PATCH] Remove -std=gnu99 CFlag when compiling C++ with clang
- (#25778)
-
-* Remove -std=gnu99 CFlag when compiling C++ with clang
-
-* Use endswith instead of hard-coded slices
-
-* Fix a typo
----
- src/python/grpcio/commands.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
-index f4a3d2bdc041..df8fc46a3cad 100644
---- a/src/python/grpcio/commands.py
-+++ b/src/python/grpcio/commands.py
-@@ -258,10 +258,14 @@ def compiler_ok_with_extra_std():
- old_compile = self.compiler._compile
-
- def new_compile(obj, src, ext, cc_args, extra_postargs, pp_opts):
-- if src[-2:] == '.c':
-+ if src.endswith('.c'):
- extra_postargs = [
- arg for arg in extra_postargs if not '-std=c++' in arg
- ]
-+ elif src.endswith('.cc') or src.endswith('.cpp'):
-+ extra_postargs = [
-+ arg for arg in extra_postargs if not '-std=gnu99' in arg
-+ ]
- return old_compile(obj, src, ext, cc_args, extra_postargs,
- pp_opts)
-
diff --git a/dev-python/grpcio/grpcio-1.37.1-r1.ebuild b/dev-python/grpcio/grpcio-1.37.1-r1.ebuild
deleted file mode 100644
index 4a41d63de85e..000000000000
--- a/dev-python/grpcio/grpcio-1.37.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 multiprocessing prefix
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-RDEPEND="
- >=dev-libs/openssl-1.0.2:0=[-bindist(-)]
- >=dev-libs/re2-0.2021.04.01:=
- >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- net-dns/c-ares:=
- sys-libs/zlib:=
-"
-
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/1.37.1-cxx-no-gnu99.patch"
- "${FILESDIR}/1.37.1-cc-flag-test-fix.patch"
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- hprefixify setup.py
-}
-
-python_configure_all() {
- # os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
- export GRPC_BUILD_WITH_BORING_SSL_ASM=
- export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
- export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
- export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
- export GRPC_PYTHON_BUILD_WITH_SYSTEM_RE2=1
- export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
- export GRPC_PYTHON_BUILD_WITH_CYTHON=1
- export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
-}