summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-03 12:41:25 +0000
committerSam James <sam@gentoo.org>2021-02-03 12:41:25 +0000
commit13ef4a5cc96bb68e6ca3d479b056af30b7d8f444 (patch)
tree64cea32ea2a31409a9ff820f8abb1ef00cce699b
parentsys-apps/usb_modeswitch: Bump to version 2.6.0 (diff)
downloadgentoo-13ef4a5cc96bb68e6ca3d479b056af30b7d8f444.tar.gz
gentoo-13ef4a5cc96bb68e6ca3d479b056af30b7d8f444.tar.bz2
gentoo-13ef4a5cc96bb68e6ca3d479b056af30b7d8f444.zip
dev-python/pypcap: add Python 3.8+, regenerate w/ Cython
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pypcap/pypcap-1.2.3-r1.ebuild (renamed from dev-python/pypcap/pypcap-1.2.3.ebuild)28
1 files changed, 18 insertions, 10 deletions
diff --git a/dev-python/pypcap/pypcap-1.2.3.ebuild b/dev-python/pypcap/pypcap-1.2.3-r1.ebuild
index 345238ce8b9f..d2b7e4073d38 100644
--- a/dev-python/pypcap/pypcap-1.2.3.ebuild
+++ b/dev-python/pypcap/pypcap-1.2.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_7 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
@@ -13,18 +14,25 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="
- net-libs/libpcap
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
PATCHES=(
"${FILESDIR}"/${PN}-1.2.3-mktemp.patch
)
python_compile() {
local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ # Needed to gain Python 3.9 compatibility
+ cython pcap.pyx || die "Failed to regenerate pcap.pyx"
+
+ # Now build as usual
distutils-r1_python_compile
}
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" test.py || die
+}