summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-04-17 20:10:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-10 09:20:02 +0300
commit13f7316344add346e1c6957d9feff1364ef9d36e (patch)
tree0c14d5187c9ff39aed4a679049b113c144539cf4
parentdev-libs/poco: drop 1.12.2-r2 (diff)
downloadgentoo-13f7316344add346e1c6957d9feff1364ef9d36e.tar.gz
gentoo-13f7316344add346e1c6957d9feff1364ef9d36e.tar.bz2
gentoo-13f7316344add346e1c6957d9feff1364ef9d36e.zip
dev-libs/poco: drop 1.11.2-r1
Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-libs/poco/Manifest1
-rw-r--r--dev-libs/poco/poco-1.11.2-r1.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/dev-libs/poco/Manifest b/dev-libs/poco/Manifest
index 7099eece610d..b81b94f9f4bd 100644
--- a/dev-libs/poco/Manifest
+++ b/dev-libs/poco/Manifest
@@ -1,2 +1 @@
-DIST poco-1.11.2.tar.gz 10935312 BLAKE2B 66b4cdb6cb4b5dd4f5f0eee744e1d147d66e98561ec4286ed09693b638d565fbf084c3e40eff3f6a9a88cff167b1d774da08e8c8424986aefe13d029a540afe2 SHA512 3f9e46dbfb0a85f19389b269725cb6272172d993d8239f13da8110c0c6ce9ed2b6595708d5dba91a027292c74358c87da988e22587a74011e84707816a6a277c
DIST poco-1.12.4.tar.gz 11296139 BLAKE2B 45e1214616e78041d5ca512cee46621c006fe21f51231f3261dc40ca4941eb3cd4e52db493aa826779784f9d3f35cfd08e3e9d08fb35ebec2d610fb6528c635a SHA512 730700a24b5a00d44aa85914e7d3c9eff76969a123a67315ba5e9b2d18c0ace70d2664d8a611496851f497aa4985d36685a67813a95e814461ae0fffdb460d91
diff --git a/dev-libs/poco/poco-1.11.2-r1.ebuild b/dev-libs/poco/poco-1.11.2-r1.ebuild
deleted file mode 100644
index e9754d726988..000000000000
--- a/dev-libs/poco/poco-1.11.2-r1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C++ libraries for building network-based applications"
-HOMEPAGE="https://pocoproject.org/"
-SRC_URI="https://github.com/pocoproject/${PN}/archive/${P}-release.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${P}-release"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc64 x86"
-IUSE="7z activerecord cppparser +crypto +data examples +file2pagecompiler iodbc +json mariadb +mongodb mysql +net odbc +pagecompiler pdf pocodoc sqlite +ssl test +util +xml +zip"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- 7z? ( xml )
- file2pagecompiler? ( pagecompiler )
- iodbc? ( odbc )
- mongodb? ( data )
- mysql? ( data )
- odbc? ( data )
- pagecompiler? ( json net util xml )
- pocodoc? ( cppparser util xml )
- sqlite? ( data )
- ssl? ( util )
- test? ( data? ( sqlite ) json util xml )
-"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- >=dev-libs/libpcre-8.42
- activerecord? ( !app-arch/arc )
- mysql? ( !mariadb? ( dev-db/mysql-connector-c:0= )
- mariadb? ( dev-db/mariadb-connector-c:0= ) )
- odbc? (
- iodbc? ( dev-db/libiodbc )
- !iodbc? ( dev-db/unixODBC )
- )
- sqlite? ( dev-db/sqlite:3 )
- ssl? (
- dev-libs/openssl:0=
- )
- xml? ( dev-libs/expat )
- zip? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.10.1-iodbc-incdir.patch" )
-
-src_prepare() {
- cmake_src_prepare
-
- if use test ; then
- # ignore missing tests on experimental library
- # and tests requiring running DB-servers, internet connections, etc.
- sed -i -e '/testsuite/d' \
- {Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF,Redis}/CMakeLists.txt || die
- # Poco expands ~ using passwd, which does not match $HOME in the build environment
- sed -i -e '/CppUnit_addTest.*testExpand/d' \
- Foundation/testsuite/src/PathTest.cpp || die
- # ignore failing Crypto test since upstream does not seem to care,
- # see https://github.com/pocoproject/poco/issues/1209
- sed -i -e '/RSATest, testRSACipherLarge/d' \
- Crypto/testsuite/src/RSATest.cpp || die
- fi
-
- if use mariadb ; then
- # Fix MariaDB detection
- sed -i -e 's~/usr/include/mysql~~' \
- -e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
- cmake/FindMySQL.cmake || die
- else
- # Fix MySQL detection
- sed -i -e 's/mysqlclient_r/mysqlclient/' \
- -e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
- cmake/FindMySQL.cmake || die
- fi
-
- # Add missing directory that breaks the build
- mkdir -p Encodings/testsuite/data || die
-
- if ! use iodbc ; then
- sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die
- fi
-}
-
-src_configure() {
- # apache support is dead and buggy, https://github.com/pocoproject/poco/issues/1764
- local mycmakeargs=(
- -DPOCO_UNBUNDLED=ON
- -DENABLE_APACHECONNECTOR=OFF
- -DENABLE_ACTIVERECORD="$(usex activerecord)"
- -DENABLE_ACTIVERECORD_COMPILER="$(usex activerecord)"
- -DENABLE_CPPPARSER="$(usex cppparser)"
- -DENABLE_CRYPTO="$(usex ssl)"
- -DENABLE_DATA="$(usex data)"
- -DENABLE_DATA_MYSQL="$(usex mysql)"
- -DENABLE_DATA_ODBC="$(usex odbc)"
- -DENABLE_DATA_SQLITE="$(usex sqlite)"
- -DENABLE_DATA_POSTGRESQL=OFF
- -DENABLE_JSON="$(usex util)"
- -DENABLE_MONGODB="$(usex mongodb)"
- -DENABLE_NET="$(usex net)"
- -DENABLE_NETSSL="$(usex ssl)"
- -DENABLE_NETSSL_WIN=OFF
- -DENABLE_PAGECOMPILER="$(usex pagecompiler)"
- -DENABLE_PAGECOMPILER_FILE2PAGE="$(usex file2pagecompiler)"
- -DENABLE_PDF="$(usex pdf)"
- -DENABLE_POCODOC="$(usex pocodoc)"
- -DENABLE_SEVENZIP="$(usex 7z)"
- -DENABLE_TESTS="$(usex test)"
- -DENABLE_UTIL="$(usex util)"
- -DENABLE_XML="$(usex xml)"
- -DENABLE_ZIP="$(usex zip)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- POCO_BASE="${S}" cmake_src_test
-}
-
-src_install() {
- cmake_src_install
-
- if use examples ; then
- for sd in */samples ; do
- docinto examples/${sd%/samples}
- dodoc -r ${sd}
- done
-
- find "${D}/usr/share/doc/${PF}/examples" \
- -iname "*.sln" -or -iname "*.vcproj" -or \
- -iname "*.vmsbuild" -or -iname "*.properties" \
- | xargs rm -v || die
- fi
-}