summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-07 22:19:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-07 22:22:34 +0200
commit140284e9804fea1a3472985a523c0e92cd2867b9 (patch)
tree160da15face9c131408f400007969b6039828bd6
parentdev-util/blueprint-compiler: fix wrong python shebang (diff)
downloadgentoo-140284e9804fea1a3472985a523c0e92cd2867b9.tar.gz
gentoo-140284e9804fea1a3472985a523c0e92cd2867b9.tar.bz2
gentoo-140284e9804fea1a3472985a523c0e92cd2867b9.zip
app-emacs/god-mode: new package; add 2.18.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/god-mode/Manifest1
-rw-r--r--app-emacs/god-mode/files/50god-mode-gentoo.el9
-rw-r--r--app-emacs/god-mode/god-mode-2.18.0.ebuild33
-rw-r--r--app-emacs/god-mode/metadata.xml19
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/god-mode/Manifest b/app-emacs/god-mode/Manifest
new file mode 100644
index 000000000000..1c490a822188
--- /dev/null
+++ b/app-emacs/god-mode/Manifest
@@ -0,0 +1 @@
+DIST god-mode-2.18.0.tar.gz 27122 BLAKE2B b6af161fa3276e9393d44f4dd92393b0eb7239e49e29e3ba917e9b7f23b63d1d3432773dbfa075ed072a626c2bbd12c11625ec0dccb0733c58984b3f990add5d SHA512 3bcf170697cea8748f683a20e71e434efe4200dd72478568a370ea9f9c5658475b554f3fa5f2f79eaff443bd02fa0595389e4fb05af05d99f3bc891af46c224b
diff --git a/app-emacs/god-mode/files/50god-mode-gentoo.el b/app-emacs/god-mode/files/50god-mode-gentoo.el
new file mode 100644
index 000000000000..46f7a9b1f48f
--- /dev/null
+++ b/app-emacs/god-mode/files/50god-mode-gentoo.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'god-execute-with-current-bindings "god-mode"
+ "Execute a single command from God mode, preserving current keybindings." t)
+(autoload 'god-local-mode "god-mode"
+ "Minor mode for running commands." t)
+(autoload 'god-mode "god-mode"
+ "Toggle global `god-local-mode'." t)
+(autoload 'god-mode-all "god-mode"
+ "Toggle `god-local-mode' in all buffers." t)
diff --git a/app-emacs/god-mode/god-mode-2.18.0.ebuild b/app-emacs/god-mode/god-mode-2.18.0.ebuild
new file mode 100644
index 000000000000..661e49b70103
--- /dev/null
+++ b/app-emacs/god-mode/god-mode-2.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for God-like command entering in GNU Emacs"
+HOMEPAGE="https://github.com/emacsorphanage/god-mode/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/ansi
+ app-emacs/ecukes
+ app-emacs/ecukes
+ app-emacs/f
+ )
+"
+
+DOCS=( .github/CONTRIBUTING.md .github/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ecukes --debug --reporter spec --verbose || die "tests failed"
+}
diff --git a/app-emacs/god-mode/metadata.xml b/app-emacs/god-mode/metadata.xml
new file mode 100644
index 000000000000..754124d4374f
--- /dev/null
+++ b/app-emacs/god-mode/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This is a global minor mode for entering Emacs commands without modifier
+ keys. It's similar to Vim's separation of command mode and insert mode. All
+ existing key bindings will work in God mode. It's only there to reduce your
+ usage of modifier keys.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacsorphanage/god-mode/issues/</bugs-to>
+ <remote-id type="github">emacsorphanage/god-mode</remote-id>
+ </upstream>
+</pkgmetadata>