summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-10 05:49:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-10 05:56:22 +0100
commit14231e5cd406d31ef848184473e90318b8413fe7 (patch)
tree64a0751ae453d2668afdc11b6e005b41ca05c127
parentdev-python/iminuit: Bump to 2.9.0 (diff)
downloadgentoo-14231e5c.tar.gz
gentoo-14231e5c.tar.bz2
gentoo-14231e5c.zip
dev-python/rfc3986: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-2.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index f651ecd63b59..70693b1b34f1 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1 +1,2 @@
DIST rfc3986-1.5.0.tar.gz 49378 BLAKE2B f5ef923626fdcbe4d13729a5599012a8a93d234eef7f9ac9dc61620320062a69646f810a8f0ea04f371b9c423850982685e68201f08ba96ad9ead3ab11a9b40d SHA512 b291b88b6890f8c9fcfc353e05d1b8c0435be62f22768568ecf714af083b3c51d7a9b301fc9196d37ad4e6eeb8c6a237ba40914098e755b4ccdf36b7df7906c2
+DIST rfc3986-2.0.0.tar.gz 49026 BLAKE2B 41e1ab9d1ad878336dc93fa0924c6cc90930d5fd3ba0bbb238be402512d3227cacfa555828c5d698810bee74b3b77f045abb7fcb5c854a4f49922f4cbe05004f SHA512 5c8370cb1e21811eaab91269b9a30972b8fbcbe1fa1d806fd3ceabe0e1937de856d757146137fee470fbdbcc7e948b236f72a42306da41a6d03807e7333983df
diff --git a/dev-python/rfc3986/rfc3986-2.0.0.ebuild b/dev-python/rfc3986/rfc3986-2.0.0.ebuild
new file mode 100644
index 000000000000..ac5f51cdb658
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="idna"
+
+RDEPEND="
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest