summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 15:30:38 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 17:13:36 -0800
commit14240f9670e45f722750d2ff39e3c8ddd10199e8 (patch)
tree5a9af6e5f79dc72756ca8e9eb8f731f24025b33b
parentdev-python/webencodings: Revbump, add py37 (diff)
downloadgentoo-14240f96.tar.gz
gentoo-14240f96.tar.bz2
gentoo-14240f96.zip
dev-python/u-msgpack: Version bump to 2.5.2, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/u-msgpack/Manifest1
-rw-r--r--dev-python/u-msgpack/u-msgpack-2.4.1.ebuild2
-rw-r--r--dev-python/u-msgpack/u-msgpack-2.5.2.ebuild22
3 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/u-msgpack/Manifest b/dev-python/u-msgpack/Manifest
index 0a3c9d97e2f2..db233f75de1d 100644
--- a/dev-python/u-msgpack/Manifest
+++ b/dev-python/u-msgpack/Manifest
@@ -1 +1,2 @@
DIST u-msgpack-2.4.1.tar.gz 12026 BLAKE2B d8f9c5558daba3afda53c4c1b8e10edd6baa08a58c82796171ae0752c10c638b76abc608349e2ba090e83b2df66611a5c0c03febd38c2a13c45fb617b6bcf74f SHA512 4c3edb72455e8eb8fa7a4ed9b6ef4461755b782391f2c362d52d0fafda3e790fb40d0d239d05ba99beb3ad4cfd9e200175e2a1917cd64ee1e5d8cc3c4e8b3f25
+DIST u-msgpack-2.5.2.tar.gz 17641 BLAKE2B 643984fd9ed2f87ad0cce9e64aaa064465048067098bf01bd844a04bc1b870d6688eac6bc9f1dddf9bf705fb14bc332796f06b8b59d0dfe79261e85ba11b60d1 SHA512 cefba7ed86d2b7c37b0d92e3a4fb4ec62c89dffee0be078c783010638413e6ce1af7ab959b43dfedb6fd8cf2943185c18fc2201a4a9764c423e8242bcedf21a9
diff --git a/dev-python/u-msgpack/u-msgpack-2.4.1.ebuild b/dev-python/u-msgpack/u-msgpack-2.4.1.ebuild
index 813f83f755c0..635dc8714d8d 100644
--- a/dev-python/u-msgpack/u-msgpack-2.4.1.ebuild
+++ b/dev-python/u-msgpack/u-msgpack-2.4.1.ebuild
@@ -22,6 +22,8 @@ RDEPEND=""
DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
S=${WORKDIR}/${MY_P}
PATCHES=("${FILESDIR}"/${P}-little-endian.patch)
diff --git a/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild b/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild
new file mode 100644
index 000000000000..c128ce847af0
--- /dev/null
+++ b/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest