summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-13 13:43:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-14 00:55:47 +0200
commit142443918666464d989b213f821bc14ca2935be7 (patch)
tree7906bc952bebcc08dbefbc91f92bd39c36a46171
parentapp-emacs/exec-path-from-shell: bump to 2.2 (diff)
downloadgentoo-14244391.tar.gz
gentoo-14244391.tar.bz2
gentoo-14244391.zip
app-emacs/nginx-mode: bump to 1.1.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/nginx-mode/Manifest1
-rw-r--r--app-emacs/nginx-mode/nginx-mode-1.1.10.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/nginx-mode/Manifest b/app-emacs/nginx-mode/Manifest
index fab6b69bfc87..68b5d4977076 100644
--- a/app-emacs/nginx-mode/Manifest
+++ b/app-emacs/nginx-mode/Manifest
@@ -1 +1,2 @@
+DIST nginx-mode-1.1.10.tar.gz 3204 BLAKE2B e252c386d00e6c2a43ae4a8583189d4c06bf166e230b81b0f59449050376d539a7966f2e44a09ae70b42c5b51ea74fc8f84a1f15ebcb502f69001b2d564bd9e5 SHA512 93801701322afdbd6f02152108d69abd050bda9456b2016446d03c22ff1c886ec0d14da4be07f49c02ab2346b45480926c0ea4c00769233e4b32ad1a7cff4f00
DIST nginx-mode-1.1.9.tar.gz 3290 BLAKE2B 7a20632ed860e1e4f0f379f8c489bdb3f6a1eb09cf790ca4124dd08b631a101796fb96efc73672cc59b812c0136015d955a9d6bab2ccb223d777f299dd1c04c7 SHA512 a209b83f39696ccea8d45b0d90a25b4cdb56f85f1288ca9a7bf83b24a7d69ae2a1caea5e71f7c62ef693f8aac3e74e5dce7761b69ded7da037904df1c9d43536
diff --git a/app-emacs/nginx-mode/nginx-mode-1.1.10.ebuild b/app-emacs/nginx-mode/nginx-mode-1.1.10.ebuild
new file mode 100644
index 000000000000..272a59e9de15
--- /dev/null
+++ b/app-emacs/nginx-mode/nginx-mode-1.1.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs editing mode for Nginx config files"
+HOMEPAGE="http://github.com/ajc/nginx-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ajc/${PN}.git"
+else
+ SRC_URI="https://github.com/ajc/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}