summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-16 01:37:04 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-16 01:40:26 -0400
commit142c68ae386ee1a9ca0cfa59449d77372eb4c106 (patch)
tree7ef1eb2f569e267c528c1c4d73bcf5b96ecd4ee3
parentdev-lang/julia: Update live ebuild (diff)
downloadgentoo-142c68ae386ee1a9ca0cfa59449d77372eb4c106.tar.gz
gentoo-142c68ae386ee1a9ca0cfa59449d77372eb4c106.tar.bz2
gentoo-142c68ae386ee1a9ca0cfa59449d77372eb4c106.zip
dev-python/pluggy: version bump to 0.5.2
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-0.5.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index cc56a7cc36cc..20337c9be14b 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-0.4.0.zip 19054 SHA256 dd841b5d290b252cf645f75f3bd37ceecfa0f36394ab313e4f785fe68a4081a4 SHA512 1a6e28df05751767df1ac3dfac4c29ba0367f05ae9c8c6a7f5163bb53de36f90226ed18baedeb41bc8ca23504ca61a9b32ef907d3ec3fee7512bcdf45a56d19c WHIRLPOOL 6fe852f807f8966d5df39a118871097758885c95c7aa1e722278704c8ccfaee14e6c18abf7e2033e4801aa0934a2ff0eb64ac3a8db5a53fc86841f6a9cf688cc
+DIST pluggy-0.5.2.tar.gz 18935 SHA256 bd60171dbb250fdebafad46ed16d97065369da40568ae948ef7117eee8536e94 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb WHIRLPOOL ae602eedb539f3e2b995edb474edf9de6a6637e6eee6e78987b43c6bcbfe8e9984beb9d1cbf5f33ac5e50367ea0a4ef2c69620fa3b776b0ed885e95b5878b020
diff --git a/dev-python/pluggy/pluggy-0.5.2.ebuild b/dev-python/pluggy/pluggy-0.5.2.ebuild
new file mode 100644
index 000000000000..5e95a9c8147e
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE=" http://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}