summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-25 06:14:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-25 07:02:00 +0100
commit1450d26551bddff362ffe8e204c14d57790accd4 (patch)
tree8a2a1a194f4dc15a6b05de927258c627f2d91694
parentapp-editors/vis: Stabilize 0.8 amd64, #896384 (diff)
downloadgentoo-1450d265.tar.gz
gentoo-1450d265.tar.bz2
gentoo-1450d265.zip
dev-python/botocore: Bump to 1.29.79
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.79.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e21740823cbf..c94620192e71 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.75.gh.tar.gz 11152953 BLAKE2B 69c9c520f1caa97d931bc535261e14f
DIST botocore-1.29.76.gh.tar.gz 11172494 BLAKE2B 7ed171f64b17920fe6492faa1422a5d82852697e4480c4e1c5536450c2671e57ee763f9b507e9ff5edff85a02553ccd94687095bbf7a4635553a3770f9c26b06 SHA512 0a22fb2629f604ef4bb4c02e6ac5f87986724d484e6d13966dae2800f989f598d82f0904473f4ac6fa2bb9e9a9572c15fb309f9ababdbea334ae8d5d4bd73287
DIST botocore-1.29.77.gh.tar.gz 11175009 BLAKE2B c67571941ee06c6dd25dfad203c86ae9de12ba8ff5948260c58ec1fa934714ce03c22833354acd116e32958d324fe2cbfbd53bb79dc378d0ec8a30a775036403 SHA512 86f377438d652380aea6028162ad2f64ccfc128a2239c99133a0a2818f0d7bb8bdb5e5772a5835e92e4b895a07cb67466124f713aea61f6ab2b4e4ac080a9c65
DIST botocore-1.29.78.gh.tar.gz 11181688 BLAKE2B 925a286e17a8def701edcfc736203981463b6060ce8a4b8af55167080d3a6ec0ef10d198fa07c0b343ef42946b01c6d3b727f02a51aab667a4f8d7373656bfbe SHA512 a8c80cbc6a2db0de9fc0e1832363025cbcc7a770ac358ae2d1396164836b49f1b985dd5cf10e8c941284c9afb8318d63e3d5fbeec9ef171b147b58ed34a26d2d
+DIST botocore-1.29.79.gh.tar.gz 11184048 BLAKE2B 062326a477fb27844ec47af28b77424863d6ff407dbcfd95bc9aa26d4009f503364f3d438997fe437b4830b8ef8c7bfb7e026313364bb3e9429cd3b7c2eae261 SHA512 260cf6a533e32c6f514774e5c5ef6830feb77058e1074e730d7fa05fb7067dac093f1a612ed11e02db116671ca9f7301ed29e1625f6e47724301d25b03eb3c30
diff --git a/dev-python/botocore/botocore-1.29.79.ebuild b/dev-python/botocore/botocore-1.29.79.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.79.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}