summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-12 09:50:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-12 10:42:53 +0200
commit14711ac77d24f54dec6d3d4634e3c6301bd0523c (patch)
tree23780f77cca255d801afffb9a82f740e2f0d3106
parentdev-python/gitdb: Bump to 4.0.4 (diff)
downloadgentoo-14711ac77d24f54dec6d3d4634e3c6301bd0523c.tar.gz
gentoo-14711ac77d24f54dec6d3d4634e3c6301bd0523c.tar.bz2
gentoo-14711ac77d24f54dec6d3d4634e3c6301bd0523c.zip
dev-python/GitPython: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/GitPython/GitPython-3.1.1.ebuild57
-rw-r--r--dev-python/GitPython/Manifest1
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.1.ebuild b/dev-python/GitPython/GitPython-3.1.1.ebuild
new file mode 100644
index 000000000000..4c35f34de642
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-3.1.0
+GITDB_P=gitdb-4.0.2
+SMMAP_P=smmap-3.0.1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ # remove performance tests
+ rm -r git/test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' git/test/test_remote.py || die
+ # broken apparently
+ sed -i -e 's:test_rev_parse:_&:' git/test/test_repo.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index ea18deb602d6..8788c45d60fc 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,5 +1,6 @@
DIST GitPython-2.1.11.tar.gz 428531 BLAKE2B 18b00f1e622c6588c14e1625f944d117348fb77e67161117510f42c8381db8cde8c6e16fa911edabfc4410239622fb845931b247bab4133585d2ec27969fea4c SHA512 5f964ee56c3f27c28f502150216af29b8463b19d9c0f773458dbabf17ba8587ee5c5e3fbcb31ad46c55e202d06bae447fd40007890a1bc116fe0370cdfc6401f
DIST GitPython-3.1.0.gitbundle 8618276 BLAKE2B a1ecf49c47804b399453c6931fb54903309944b47a5a8ccd02d62f4b27943e60b4b58a9e67567008fa4d5bc791b1c86642659c045c885e2155e2c44bb1a4ea81 SHA512 a71463f861f840d3169a8351155665243d9f0f0a72e210940f9f7872cfd49b6ddfac827f0ec5bc61079d8066fc7ba210a03dd99f3bbd598e22ccbcacfe8e61b3
DIST GitPython-3.1.0.tar.gz 430079 BLAKE2B eaf4d4bb2f589a96bcdcf28e7ac6c0b8eab691a1dee5fbbec6d4a93bab9f123b07073af8a1b85aa5547057e46e6c8c004215167790b559f3848bf20c3ec1697f SHA512 6dab8449cc1736d7f58f9788b56bf63cc2bf0f420104d6e010a9624d21f53f5b5d33135bad4d91b40d9543b454be839f8003828ffe512c35a6513c27a2dd4b53
+DIST GitPython-3.1.1.tar.gz 430310 BLAKE2B f6402c4f8d72f4352bf97b72ac0c39b347683c411dcb7b74405119773954a185fe7dc11e13232d56f4a9f938e64b865f42cbd3a857427d985e29f024eb4e0880 SHA512 a913fb611479456d4b804c56039ed8d8ac8cb183f58c874e265141f2b5b46befd4a8a2f5d94ac1cf8ea7fc99e901568a9fc054d50df0ac242d7d184add8ca1b3
DIST gitdb-4.0.2.gitbundle 1474197 BLAKE2B 93dc8aeb3a43f0950bec1e8dc0c0156543a0a1ce1f20a7f0b2cd05c110338af05b6c6300c3f4b2c05e0f895496248e5fdca74eb599a4ea9aa983ed399d91f7c6 SHA512 8d4ebc93d6869a60b7717fc090000067e86a7e0373c281d0fb9939a6e2e283864256f827919eeb13be977254c0c71a4864d8e7c9b4b6dcc0af6275aa59681960
DIST smmap-3.0.1.gitbundle 263781 BLAKE2B 6e06586010814ce0f59367c7f9289dad4891ee1debbc020b192af3945207da05b1e34907f1871f5b6b9638706b9e2fdacf390fcfff6bd06af84b9fd80f7e63a8 SHA512 c2b6c0b295c2997ed53727d3d1458ae7ec5ddbde9c83349286904726865fc026a70161955498b1a06371fb8d937e7386b80b4ea0c2e5d1c647718e6dbea93104