summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-13 07:40:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-13 07:51:43 +0100
commit1474874edcfaba9f4e78e64197d268160c2126dd (patch)
treef35ddf393631fa06ac5b488d44f4c9869bbc4d1b
parentdev-python/python-novaclient: Bump to 18.6.0 (diff)
downloadgentoo-1474874edcfaba9f4e78e64197d268160c2126dd.tar.gz
gentoo-1474874edcfaba9f4e78e64197d268160c2126dd.tar.bz2
gentoo-1474874edcfaba9f4e78e64197d268160c2126dd.zip
dev-python/comm: Bump to 0.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/comm/Manifest1
-rw-r--r--dev-python/comm/comm-0.2.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index 92fe65cf363b..254c5f1207f6 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1 +1,2 @@
DIST comm-0.2.1.gh.tar.gz 9569 BLAKE2B 5af0ba4f82ee69819404cef7e45937d9cfeec0a390c7bf562dce1132a7b916a5d8c80c25f7d78cc44f3fb069959d6c8902aae61ecd4bb07e3036d096e25d35cf SHA512 79f85dcd06a5e849718092a3148f39ad81c36a1903a51bd619f50d044cec6be7ca25e3fe7cd85c9174d76558b52dc77a1c3b49f1ed52b8f83e83a8a6ae7f3f0d
+DIST comm-0.2.2.gh.tar.gz 9983 BLAKE2B aedbd55751cbf58b2e7adad5e59af1aa1479e653bb7b62f811686a30630682edfd6fe82e18ed14d9f7a4b875e2596fba375eb34493f3d29eeeb6ca1b7bdd7c71 SHA512 a37999859894186cb52f50835459dd6c3aced256ed1c6319660c98ad9e423f4ab1fd86545f68c82fbbbd74dcec70359566307cecbc3610d806084a33fae9e693
diff --git a/dev-python/comm/comm-0.2.2.ebuild b/dev-python/comm/comm-0.2.2.ebuild
new file mode 100644
index 000000000000..6ddbbf5df8d5
--- /dev/null
+++ b/dev-python/comm/comm-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest