summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-09-08 14:02:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-09-08 14:02:53 -0500
commit14859b8fdba893064b20667ca3f478e26b5a2657 (patch)
tree8ef84fd604160d723ac3abbf3fdce1aeebdd344c
parentdev-lang/go: 1.7.1 version bump (diff)
downloadgentoo-14859b8fdba893064b20667ca3f478e26b5a2657.tar.gz
gentoo-14859b8fdba893064b20667ca3f478e26b5a2657.tar.bz2
gentoo-14859b8fdba893064b20667ca3f478e26b5a2657.zip
dev-lang/go: sync live ebuild
Package-Manager: portage-2.2.28
-rw-r--r--dev-lang/go/go-9999.ebuild32
1 files changed, 2 insertions, 30 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 7adeb6be1656..58d44c510fa3 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -28,6 +28,7 @@ kernel_linux? (
${BOOTSTRAP_DIST}/go-linux-ppc64-bootstrap.tbz
${BOOTSTRAP_DIST}/go-linux-ppc64le-bootstrap.tbz
)
+ s390? ( ${BOOTSTRAP_DIST}/go-linux-s390x-bootstrap.tbz )
x86? ( ${BOOTSTRAP_DIST}/go-linux-386-bootstrap-1.tbz )
)
kernel_SunOS? (
@@ -89,6 +90,7 @@ go_arch()
x86) echo 386;;
x64-*) echo amd64;;
ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
+ s390) echo s390x ;;
*) echo "${portage_arch}";;
esac
}
@@ -218,33 +220,3 @@ src_install()
done
dodoc AUTHORS CONTRIBUTORS PATENTS README.md
}
-
-pkg_preinst()
-{
- has_version '<dev-lang/go-1.4' &&
- export had_support_files=true ||
- export had_support_files=false
-}
-
-pkg_postinst()
-{
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-
- if $had_support_files; then
- ewarn
- ewarn "All editor support, IDE support, shell completion"
- ewarn "support, etc has been removed from the go package"
- ewarn "upstream."
- ewarn "For more information on which support is available, see"
- ewarn "the following URL:"
- ewarn "https://github.com/golang/go/wiki/IDEsAndTextEditorPlugins"
- fi
-}