summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-02 10:56:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-02 10:59:38 +0200
commit14862bdd368de259024c427b18eff48267e740e0 (patch)
tree1b0a0f8b1a70afd76ac346d4ff5336a346900bf5
parentx11-terms/alacritty: remove CC export (diff)
downloadgentoo-14862bdd.tar.gz
gentoo-14862bdd.tar.bz2
gentoo-14862bdd.zip
app-shells/dash: Bump to version 0.5.11
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-shells/dash/Manifest1
-rw-r--r--app-shells/dash/dash-0.5.11.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index a950fe55632d..0ee67432d184 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,2 +1,3 @@
DIST dash-0.5.10.2.tar.gz 225196 BLAKE2B af48879d29aee8041949b51f08eb89c3938e77b2e05553a3e1a9939da7b00fd80f7b9fb35f33e18b0c11850bfb1b8377e9dc9bcfd80754fd29c9d160e0ce5a4d SHA512 0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640
+DIST dash-0.5.11.tar.gz 238776 BLAKE2B 0d399b35c10a33f6a22f51f7b74b9e092fb11d47ae45948f43fab0dd1416061145e7f930f0f0d1119d02cc45790ba19ce040c951322c131e706e5f3f32f2612b SHA512 41c3afa8aa4788f7899b9a4c1bce2dc8629f4405184cdc7269993e72c695cf9537c9e68b654d56f06c604a82ffa73c9160b91368e82a3593a12ff7dea10505d1
DIST dash-0.5.9.1.tar.gz 225217 BLAKE2B a80aa00ea5418d00b03c9ded21ef5c3a28d599059d1ac2f20082867b71ece6afac2f0bce9bc09946450c7618ad2c7f95df63b3d519a7f56552a291d09e44a71b SHA512 d56a043b8fab4693d3f70cceb531c37174e7ded4acd5549e53048d7ce29125ff21d7e758f51a4a73e06250d051e246467039989275838c19a2579edea3f72b7d
diff --git a/app-shells/dash/dash-0.5.11.ebuild b/app-shells/dash/dash-0.5.11.ebuild
new file mode 100644
index 000000000000..1bd542ff8270
--- /dev/null
+++ b/app-shells/dash/dash-0.5.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Debian Almquist Shell"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libedit static"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
+
+src_prepare() {
+ default
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Use pkg-config for libedit linkage
+ sed -i \
+ -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
+ configure || die
+}
+
+src_configure() {
+ # don't redefine stat on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ export ac_cv_func_stat64=yes
+
+ # if your headers strictly adhere to POSIX, you'll need this too
+ [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
+ fi
+ append-cppflags -DJOBS=$(usex libedit 1 0)
+ use static && append-ldflags -static
+ # Do not pass --enable-glob due to #443552.
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-fnmatch
+ $(use_with libedit)
+ )
+ econf "${myeconfargs[@]}"
+}