summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 18:59:41 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 19:13:22 +0100
commit149ba2d33e2c94dc99867e8d072b4ca6a2d871c2 (patch)
treee4be05de1815aa45de12581fdd8056266b2c8116
parentsci-astronly/wcslib: version bump (diff)
downloadgentoo-149ba2d33e2c94dc99867e8d072b4ca6a2d871c2.tar.gz
gentoo-149ba2d33e2c94dc99867e8d072b4ca6a2d871c2.tar.bz2
gentoo-149ba2d33e2c94dc99867e8d072b4ca6a2d871c2.zip
dev-python/epsilon: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/epsilon/Manifest1
-rw-r--r--dev-python/epsilon/epsilon-0.7.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/epsilon/Manifest b/dev-python/epsilon/Manifest
index f78f3c15e9b4..934b196d23f9 100644
--- a/dev-python/epsilon/Manifest
+++ b/dev-python/epsilon/Manifest
@@ -1,2 +1,3 @@
DIST Epsilon-0.6.0.tar.gz 96243 SHA256 2be3a6ef877c4e17ca9dadd6b484fe31bdf16c20b949ec6a8b15677e08c512fa SHA512 0ce7ba2eb86811dc50a0e86b9f3d85be1a4f930f86659c2381a1d80455e1e86362b8719c92ae2ad951a34264e5d0649ec5de96f1179734c7fab6c3abc6fb037b WHIRLPOOL 6aa363b44a42f29ec836cf46b2fdfe3bb57541a9fe282b57ea888f4906b9c438c9eb99d5a0876cb11108b7337a0691c45810a3e44579023f0b660e8752952120
DIST Epsilon-0.7.0.tar.gz 81218 SHA256 81419d50b17a20efd75440d43e4b07fe3c2a5e6d619f39318dab9031a0680032 SHA512 d1927ca431df3233a94296ca9e1f5dd70d6d61091d23f77df2222c6472d9a5f7b55c5c8dd2a75d0fead41af862c9e3a6a0ea9a31e21447459d5182f0d677d9b2 WHIRLPOOL 8cbab28e5e05b44b521c5f66494de1e2f4bee7713487cfb9d87bfcc108dc05b6534919934fd53cb1b0dc7aee633187351973b78cfdabf0584d6b294104a05a57
+DIST Epsilon-0.7.1.tar.gz 96820 SHA256 419ab2de80e6b201455775a939c158259af90695e59474a4a7bb3cd522a7193b SHA512 ecf34a402208e514c430b4b3785df9b29f3708026ceba1301a2db8760b55111f59e7c40f868f4b642e4c7dd6c78735edbc32b2ef96ec3582e90aa2d978f06842 WHIRLPOOL 69de1d74457ce6f376537c1a8ba3adbf8cae7b2e7325d8a61ba1a1a83e1b2cc88794b5016fa37b1808e32ff61834cb215b30146d93a0e6416623afd6a4609c08
diff --git a/dev-python/epsilon/epsilon-0.7.1.ebuild b/dev-python/epsilon/epsilon-0.7.1.ebuild
new file mode 100644
index 000000000000..75b56bef484a
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon https://pypi.python.org/pypi/Epsilon"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+#Lets run some tests, having prepped them
+python_test() {
+ # No testrunner seems stipulated within the source; pytest and nosetests both work
+ nosetests ${PN}/test || die "testsuite failed under ${EPYTHON}"
+}