summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-10-23 13:03:25 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-10-23 14:24:23 +0200
commit149d632b88b00115e2d54b80594df480c9821b22 (patch)
treee81679035e4abc8eec6ea297086247f18a70e465
parentdev-java/lzma: bump to 19.00, eapi7, min java 1.8 (diff)
downloadgentoo-149d632b88b00115e2d54b80594df480c9821b22.tar.gz
gentoo-149d632b88b00115e2d54b80594df480c9821b22.tar.bz2
gentoo-149d632b88b00115e2d54b80594df480c9821b22.zip
dev-java/lzmajio: eapi7, min java 1.8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-java/lzmajio/lzmajio-0.95-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/lzmajio/lzmajio-0.95-r3.ebuild b/dev-java/lzmajio/lzmajio-0.95-r3.ebuild
new file mode 100644
index 000000000000..e4b47cccb1e9
--- /dev/null
+++ b/dev-java/lzmajio/lzmajio-0.95-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="LzmaInputStream/LzmaOutputStream interacting with underlying LZMA en-/decoders"
+HOMEPAGE="https://contrapunctus.net/league/haques/lzmajio/
+ https://github.com/league/lzmajio"
+SRC_URI="https://github.com/league/${P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/lzma:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="lzma"
+JAVA_SRC_DIR="net"