summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:36:31 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:36:31 -0400
commit14a4f4f05ada7f789e5db7991b6a0f2b76b68a23 (patch)
treeb5f355b74805bdd91cbdbef96bcf2dee85692f32
parentdev-libs/libsecp256k1: add libressl support (diff)
downloadgentoo-14a4f4f0.tar.gz
gentoo-14a4f4f0.tar.bz2
gentoo-14a4f4f0.zip
dev-libs/libxr: bump EAPI and add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/libxr/libxr-1.0.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-libs/libxr/libxr-1.0.ebuild b/dev-libs/libxr/libxr-1.0.ebuild
index 8aedc0319e16..cdd0cf775113 100644
--- a/dev-libs/libxr/libxr-1.0.ebuild
+++ b/dev-libs/libxr/libxr-1.0.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
+
DESCRIPTION="Cross-platform XML-RPC client/server library written in C"
HOMEPAGE="http://oss.zonio.net/libxr.htm"
SRC_URI="http://oss.zonio.net/releases/libxr/${P}.tar.bz2"
@@ -9,22 +11,22 @@ SRC_URI="http://oss.zonio.net/releases/libxr/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
+IUSE="libressl"
# IUSE="json"
RDEPEND=">=dev-libs/glib-2.12
- >=dev-libs/libxml2-2.6.20
- dev-libs/openssl"
-# json? ( >=dev-libs/json-c-0.3 )"
+ >=dev-libs/libxml2-2.6.20
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+# json? ( >=dev-libs/json-c-0.3 )"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-util/re2c"
-src_compile() {
- econf --without-json || die
- emake || die
+src_configure() {
+ econf --without-json
}
src_install() {
- emake DESTDIR="$D" install || die
+ emake DESTDIR="$D" install
}