summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-01 13:19:40 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-01 13:23:55 -0700
commit14b419aebb9fb2508182bb4b0405ef7884f6c2d7 (patch)
tree8294866c60b96000b2fc4b188ab4e341df175d29
parentnet-mail/courier-imap: Bump to 5.0.7 (diff)
downloadgentoo-14b419ae.tar.gz
gentoo-14b419ae.tar.bz2
gentoo-14b419ae.zip
media-libs/mesa: Drop USE=pic
Upstream commit 20294dceebc2 ("mesa: Enable asm unconditionally, now that gen_matypes is gone.") removed the -Dasm= option. I have no information about when or why the 'pic' USE flag was added, so worst case I'll at least find out why it's needed by removing it now... Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-9999.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 0fd4ae716a5f..cd10f97cc605 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -37,7 +37,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +libglvnd +llvm
- lm_sensors opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind
+ lm_sensors opencl osmesa pax_kernel selinux test unwind vaapi valgrind
vdpau vulkan vulkan-overlay wayland xa xvmc"
REQUIRED_USE="
@@ -230,13 +230,11 @@ EGIT_CHECKOUT_DIR=${S}
QA_WX_LOAD="
x86? (
- !pic? (
- usr/lib*/libglapi.so.0.0.0
- usr/lib*/libGLESv1_CM.so.1.0.0
- usr/lib*/libGLESv2.so.2.0.0
- usr/lib*/libGL.so.1.2.0
- usr/lib*/libOSMesa.so.8.0.0
- )
+ usr/lib*/libglapi.so.0.0.0
+ usr/lib*/libGLESv1_CM.so.1.0.0
+ usr/lib*/libGLESv2.so.2.0.0
+ usr/lib*/libGL.so.1.2.0
+ usr/lib*/libOSMesa.so.8.0.0
)"
llvm_check_deps() {
@@ -452,11 +450,6 @@ multilib_src_configure() {
emesonargs+=( $(meson_use pax_kernel glx-read-only-text) )
fi
- # on abi_x86_32 hardened we need to have asm disable
- if [[ ${ABI} == x86* ]] && use pic; then
- emesonargs+=( -Dasm=false )
- fi
-
if use gallium; then
gallium_enable -- swrast
emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )