summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-09-17 08:47:53 +1200
committerKent Fredric <kentnl@gentoo.org>2016-09-17 09:19:51 +1200
commit14b8f77ff4496e6cf409259dd8530f55bd154f86 (patch)
tree301c7975bb5e58a3d9bc36677c02f1236e8f85bf
parentapp-vim/thlnk: Clean up old. (diff)
downloadgentoo-14b8f77f.tar.gz
gentoo-14b8f77f.tar.bz2
gentoo-14b8f77f.zip
dev-lang/perl: Update upgrade prose to encourage depclean
Depcleans really do help a lot and you should do them lots. Note: the 5.24.0-r1 version ( which is patched here ) is not displayed to the user due to some mistakes made when flattening it, this will be rectified in a future commit. Note: Patching apparently "Old" eblits because due to a lack of clarity on how eblits actually work, it turns out that all eblit-using dev-lang/perl ebuilds are sourcing *BOTH* their own eblit entries *AND* the eblit for v5016001!!. The use of eblits here has made it impossible to clearly discern which code is actually running, and that perl 5.22* and 5.20* actually work at all is more a case of amazing amounts of good luck than actual planning. Package-Manager: portage-2.3.0
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit16
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit16
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit16
-rw-r--r--dev-lang/perl/perl-5.24.0-r1.ebuild12
4 files changed, 47 insertions, 13 deletions
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
index a7b734f4091d..e46ffc2ae573 100644
--- a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -48,8 +48,18 @@ check_rebuild() {
if has_version "<dev-lang/perl-${SHORT_PV}" ; then
echo ""
ewarn "UPDATE THE PERL MODULES:"
- ewarn "After updating dev-lang/perl you must reinstall"
- ewarn "the installed perl modules."
+ ewarn "After updating dev-lang/perl the installed Perl modules"
+ ewarn "have to be re-installed. In most cases, this is done automatically"
+ ewarn "by the package manager, but subsequent steps are still recommended"
+ ewarn "to ensure system consistency."
+ ewarn
+ ewarn "You should start with a depclean to remove any unused perl dependencies"
+ ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+ ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+ ewarn "Recommended: emerge --depclean -va"
+ ewarn
+ ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+ ewarn "remaining rebuilds portage may have missed."
ewarn "Use: perl-cleaner --all"
elif has_version dev-lang/perl ; then
# doesnot work
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
index a2b09574d163..e46ffc2ae573 100644
--- a/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -48,10 +48,18 @@ check_rebuild() {
if has_version "<dev-lang/perl-${SHORT_PV}" ; then
echo ""
ewarn "UPDATE THE PERL MODULES:"
- ewarn "After updating dev-lang/perl the installed Perl modules will"
+ ewarn "After updating dev-lang/perl the installed Perl modules"
ewarn "have to be re-installed. In most cases, this is done automatically"
- ewarn "by the package manager, but you should still call perl-cleaner to"
- ewarn "make sure your system is consistent."
+ ewarn "by the package manager, but subsequent steps are still recommended"
+ ewarn "to ensure system consistency."
+ ewarn
+ ewarn "You should start with a depclean to remove any unused perl dependencies"
+ ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+ ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+ ewarn "Recommended: emerge --depclean -va"
+ ewarn
+ ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+ ewarn "remaining rebuilds portage may have missed."
ewarn "Use: perl-cleaner --all"
elif has_version dev-lang/perl ; then
# doesnot work
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
index 9ce8e992c326..87579449f2d0 100644
--- a/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -46,10 +46,18 @@ check_rebuild() {
if has_version "<dev-lang/perl-${SHORT_PV}" ; then
echo ""
ewarn "UPDATE THE PERL MODULES:"
- ewarn "After updating dev-lang/perl the installed Perl modules will"
+ ewarn "After updating dev-lang/perl the installed Perl modules"
ewarn "have to be re-installed. In most cases, this is done automatically"
- ewarn "by the package manager, but you should still call perl-cleaner to"
- ewarn "make sure your system is consistent."
+ ewarn "by the package manager, but subsequent steps are still recommended"
+ ewarn "to ensure system consistency."
+ ewarn
+ ewarn "You should start with a depclean to remove any unused perl dependencies"
+ ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+ ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+ ewarn "Recommended: emerge --depclean -va"
+ ewarn
+ ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+ ewarn "remaining rebuilds portage may have missed."
ewarn "Use: perl-cleaner --all"
elif has_version dev-lang/perl ; then
if ( use ithreads && ! has_version dev-lang/perl[ithreads] ) || \
diff --git a/dev-lang/perl/perl-5.24.0-r1.ebuild b/dev-lang/perl/perl-5.24.0-r1.ebuild
index 0bd67107bde5..3086c8e7ed91 100644
--- a/dev-lang/perl/perl-5.24.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.24.0-r1.ebuild
@@ -73,8 +73,16 @@ check_rebuild() {
ewarn "UPDATE THE PERL MODULES:"
ewarn "After updating dev-lang/perl the installed Perl modules"
ewarn "have to be re-installed. In most cases, this is done automatically"
- ewarn "by the package manager, but you should still call perl-cleaner to"
- ewarn "make sure your system is consistent."
+ ewarn "by the package manager, but subsequent steps are still recommended"
+ ewarn "to ensure system consistency."
+ ewarn
+ ewarn "You should start with a depclean to remove any unused perl dependencies"
+ ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+ ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+ ewarn "Recommended: emerge --depclean -va"
+ ewarn
+ ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+ ewarn "remaining rebuilds portage may have missed."
ewarn "Use: perl-cleaner --all"
elif has_version dev-lang/perl ; then
if ( use ithreads && ! has_version dev-lang/perl[ithreads] ) || \