summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-10-28 18:43:57 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-10-28 19:01:42 +0000
commit14bf9eb7eb75c135112619b5992ed93a4ce9c1b0 (patch)
treedfa625273269de9e2ade4e17d1cd85332433746e
parentprofiles: unmask openjdk{,-bin,jre-bin}:8[gentoo-vm] (diff)
downloadgentoo-14bf9eb7eb75c135112619b5992ed93a4ce9c1b0.tar.gz
gentoo-14bf9eb7eb75c135112619b5992ed93a4ce9c1b0.tar.bz2
gentoo-14bf9eb7eb75c135112619b5992ed93a4ce9c1b0.zip
dev-libs/libstrophe: add new version 0.9.3
Copied from 0.9.2. The only change is that libressl-related patch has been dropped, as there is now upstream support for libressl. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--dev-libs/libstrophe/Manifest1
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
index e5c1bc327adc..2e913cf0bd1f 100644
--- a/dev-libs/libstrophe/Manifest
+++ b/dev-libs/libstrophe/Manifest
@@ -1 +1,2 @@
DIST libstrophe-0.9.2.tar.gz 500459 BLAKE2B 0b1f6f1daac1215bcdcbde0e54264b98f5a863de339500826f625f8c5e8143ce7200fb251d04248715e9a8b6621a4360e7ca2780bf4684d916ec13361b5f6fcc SHA512 a0129c49ca574afaefa77c412143571af2eb1100c7d737d497b65d44680d35e2404ee2d4d4e1378b06ac1bcc5c587f505f79fea9251af1cbb36afd990d48570d
+DIST libstrophe-0.9.3.tar.gz 502449 BLAKE2B 662b0c329b0bf7d7f34fc80bf0608b921fa1ad54c8277e88f23f3ed17d0892dc7e3d9bcaaa9707306801e9254bba4a127390025ab95e1d9d850c299a7b26d980 SHA512 9c8ba980f532c5576c2c5a9e3cdca9f833ec78debcb06b17e2f534de0e710ec416b997b0498be77a89fa7f57187456edb1d602993c695a5e738718ea593697a5
diff --git a/dev-libs/libstrophe/libstrophe-0.9.3.ebuild b/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
new file mode 100644
index 000000000000..5323315dc71e
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="|| ( MIT GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc expat libressl"
+
+RDEPEND="
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2:2 )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ # shellcheck disable=SC2207
+ local myeconf=(
+ --enable-tls
+ $(use_with !expat libxml2)
+ )
+ econf "${myeconf[@]}"
+}
+src_compile() {
+ default
+ if use doc; then
+ doxygen || die
+ HTML_DOCS=( docs/html/* )
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r examples
+ find "${D}" -name '*.la' -delete || die
+}