summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-01 02:29:23 +0100
committerSam James <sam@gentoo.org>2022-10-01 02:29:32 +0100
commit14cd6bb17f4528e9a1b21aa09f7ce4ec4b78d499 (patch)
treec8439c3bb7d03e45b192a28cabfb255ba5e79482
parentdev-lua/luv: add 1.44.2.0 (diff)
downloadgentoo-14cd6bb1.tar.gz
gentoo-14cd6bb1.tar.bz2
gentoo-14cd6bb1.zip
app-editors/neovim: add 0.8.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.8.0.ebuild131
-rw-r--r--app-editors/neovim/neovim-9999.ebuild15
3 files changed, 140 insertions, 7 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index fe903123a573..a1a7f59a5bae 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,2 +1,3 @@
DIST neovim-0.7.0.tar.gz 10925354 BLAKE2B 0524d008ba1ebbe823406e94cfb048014b26bc394c686b2dd84bb7fae5a1f7f3acd42764b03b6efec10c0f25045c5838f624542b5125947e5f42d3b0d2ad1f84 SHA512 3597c54fb925a4d607bca9ba0fdb37df90ecb816da99f52baf46cc2ec79727a55048ba1d8d22c8e7d61f0e8e35546326b1d0d15c0a91de8bf5bc529c45fb1ce0
DIST neovim-0.7.2.tar.gz 10933623 BLAKE2B c2db449a91f1685233da7125e3d4b49cb8fe26db5e498fd3a83340bd14842399474fcc7f2c78b88783195c6f7b0b8df196985b70387ed88972372a8866e2c721 SHA512 04d0fa5b23018531b70b53271821bf6944cde1bcec2210b99f5888e1339cd38f57feaa8e40874a3a504930e6614980947f31852185cbcd2ce106a0867896dd79
+DIST neovim-0.8.0.tar.gz 11387355 BLAKE2B 341f0fa10f0001324c87c26e7c0047334c25808901034f073945c3977dde4dda44b03869be1f530398d549f0b13dafae0eb82766464875ced2cd26621a0c5d88 SHA512 e9504e33df292043656b0ef064e465069c93d4be52bbe29ec33c111f3e00ed83647148d653e3f143e2243dac537eede6a9351990bd858ac20abc8edbc5249432
diff --git a/app-editors/neovim/neovim-0.8.0.ebuild b/app-editors/neovim/neovim-0.8.0.ebuild
new file mode 100644
index 000000000000..2e5948e10f45
--- /dev/null
+++ b/app-editors/neovim/neovim-0.8.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..2} luajit )
+
+inherit cmake lua-single optfeature xdg
+
+DESCRIPTION="Vim-fork focused on extensibility and agility"
+HOMEPAGE="https://neovim.io"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+lto +nvimpager test +tui"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+# Upstream say the test library needs LuaJIT
+# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
+REQUIRED_USE="test? ( lua_single_target_luajit )"
+# TODO: Get tests running
+RESTRICT="!test? ( test ) test"
+
+# Upstream build scripts invoke the Lua interpreter
+BDEPEND="${LUA_DEPS}
+ >=dev-util/gperf-3.1
+ >=sys-devel/gettext-0.20.1
+ virtual/libiconv
+ virtual/libintl
+ virtual/pkgconfig
+"
+# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
+# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
+DEPEND="${LUA_DEPS}
+ >=dev-lua/luv-1.44.2[${LUA_SINGLE_USEDEP}]
+ $(lua_gen_cond_dep '
+ dev-lua/lpeg[${LUA_USEDEP}]
+ dev-lua/mpack[${LUA_USEDEP}]
+ ')
+ $(lua_gen_cond_dep '
+ dev-lua/LuaBitOp[${LUA_USEDEP}]
+ ' lua5-{1,2})
+ >=dev-libs/libuv-1.44.2:=
+ >=dev-libs/libvterm-0.3
+ >=dev-libs/msgpack-3.0.0:=
+ >=dev-libs/tree-sitter-0.20.2:=
+ tui? (
+ >=dev-libs/libtermkey-0.22
+ >=dev-libs/unibilium-2.0.0:0=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ app-eselect/eselect-vi
+"
+BDEPEND="
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ )
+"
+
+PATCHES=()
+
+if [[ ${PV} == 9999 ]]; then
+ PATCHES+=(
+ "${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-9999-cmake-darwin.patch"
+ )
+else
+ PATCHES+=(
+ "${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-9999-cmake-darwin.patch"
+ )
+fi
+
+src_prepare() {
+ # Use our system vim dir
+ sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
+ -i src/nvim/globals.h || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Upstream default to LTO on non-debug builds
+ # Let's expose it as a USE flag because upstream
+ # have preferences for how we should use LTO
+ # if we want it on (not just -flto)
+ # ... but allow turning it off.
+ # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
+ local mycmakeargs=(
+ -DENABLE_LTO=$(usex lto)
+ -DFEAT_TUI=$(usex tui)
+ -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
+ -DLUA_PRG="${ELUA}"
+ -DMIN_LOG_LEVEL=3
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
+ optfeature "Python plugin support" dev-python/pynvim
+ optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
+ optfeature "remote/nvr support" dev-python/neovim-remote
+}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index c1e19411b835..2e5948e10f45 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -32,6 +32,7 @@ RESTRICT="!test? ( test ) test"
# Upstream build scripts invoke the Lua interpreter
BDEPEND="${LUA_DEPS}
>=dev-util/gperf-3.1
+ >=sys-devel/gettext-0.20.1
virtual/libiconv
virtual/libintl
virtual/pkgconfig
@@ -39,7 +40,7 @@ BDEPEND="${LUA_DEPS}
# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
DEPEND="${LUA_DEPS}
- >=dev-lua/luv-1.43.0[${LUA_SINGLE_USEDEP}]
+ >=dev-lua/luv-1.44.2[${LUA_SINGLE_USEDEP}]
$(lua_gen_cond_dep '
dev-lua/lpeg[${LUA_USEDEP}]
dev-lua/mpack[${LUA_USEDEP}]
@@ -47,10 +48,10 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- >=dev-libs/libuv-1.44.1:=
- >=dev-libs/libvterm-0.1.4
+ >=dev-libs/libuv-1.44.2:=
+ >=dev-libs/libvterm-0.3
>=dev-libs/msgpack-3.0.0:=
- >=dev-libs/tree-sitter-0.20.6:=
+ >=dev-libs/tree-sitter-0.20.2:=
tui? (
>=dev-libs/libtermkey-0.22
>=dev-libs/unibilium-2.0.0:0=
@@ -76,9 +77,9 @@ if [[ ${PV} == 9999 ]]; then
)
else
PATCHES+=(
- "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
- "${FILESDIR}/${PN}-0.7.2-cmake-darwin.patch"
+ "${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-9999-cmake-darwin.patch"
)
fi