summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2019-06-16 08:32:04 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-30 02:45:08 +0300
commit14f07d667f8b9db38719f3caa4983ed0e4028ff6 (patch)
treefaf8ff21723692123ee7b28451680ac0a58fb975
parentgames-arcade/xbill: add missing dependency; EAPI=7 (diff)
downloadgentoo-14f07d66.tar.gz
gentoo-14f07d66.tar.bz2
gentoo-14f07d66.zip
media-sound/fluidsynth: bump to 2.0.6, add systemd support
Closes: https://bugs.gentoo.org/688144 Closes: https://bugs.gentoo.org/665022 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Nikos Chantziaras <realnc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12264 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.0.6.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 3017ba15365a..a5576233043c 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,2 +1,3 @@
DIST fluidsynth-1.1.11.tar.gz 634566 BLAKE2B ed135533c9e3e807794e0eca8117d430aa299b8772b2b6c85f6233e7e497d69f43381d9c7cf2de5ce8638f5dc616339bd28cecc3cdc23408bf5883a0b14fee79 SHA512 ad7c634426b29e5a05d67addf32d43a9ccb11a1fe3cfc09ad617416b9df3dc99a48191377f5027232521380737dde2d9b59833516d1bffb90f410bab3bbe140c
DIST fluidsynth-2.0.4.tar.gz 1378042 BLAKE2B 0fc75ea68169c47d64bdf727b8d78e311b36cb04509832f449a52d05e085908bd1ef837dd4c5e23edc25286b8ff3fdf69a9d042520c8eb2a3234fb929bed8de5 SHA512 d58ddc5f4da9bb5954a82749617548ef32edd25f6ca5c6d5c2b06d23090784ec175d2422553a66776f543c6b253f037a6cf1e717a853344ffb899fa53752eec0
+DIST fluidsynth-2.0.6.tar.gz 1315138 BLAKE2B ce6d1717d56d61b83bef6c30254c584ddb9ee3e74fa49422881c96c969068ebe7965de507547e8bfa025da4376f52499413ff66b56607aac107576754980a0de SHA512 c160e3d7c6ad62d5cc014642eb18a0f65eb90b5ad91db4049e1b45446034e989a4f9e5b805270967d4eaf47a6e2da0e81bdb5ae95500cc80d7021e8e61cd7107
diff --git a/media-sound/fluidsynth/fluidsynth-2.0.6.ebuild b/media-sound/fluidsynth/fluidsynth-2.0.6.ebuild
new file mode 100644
index 000000000000..1fafcdd0ad95
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.0.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib systemd
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="https://github.com/FluidSynth/fluidsynth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash oss portaudio pulseaudio +readline +sndfile systemd"
+
+BDEPEND="
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-cmt[${MULTILIB_USEDEP}]
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS NEWS README.md THANKS TODO doc/{fluidsynth-v20-devdoc,xtrafluid}.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -Denable-alsa=$(usex alsa)
+ -Denable-dbus=$(usex dbus)
+ -Denable-debug=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-readline=$(usex readline)
+ -Denable-systemd=$(usex systemd)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}