summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 07:01:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 07:10:59 +0100
commit14f1a743767766aca513a8d51fb8c2f12538141e (patch)
tree4b81a8d7ad44e3cf328afb22b8d27c75f9e6e1c9
parentdev-python/deepmerge: Bump to 1.1.1 (diff)
downloadgentoo-14f1a743.tar.gz
gentoo-14f1a743.tar.bz2
gentoo-14f1a743.zip
dev-python/fonttools: Bump to 4.47.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.47.0.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 4afba3a3dc4d..99fb4d1ac573 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1 +1,2 @@
DIST fonttools-4.46.0.gh.tar.gz 3796675 BLAKE2B 5e8affb809cc2a66208636557c2bcfac58abbbd2cbb921923686153138ef011db1f00edafdf2b998c9d26924ceb6b3038b65d593892a379b7c72fdaf8df10304 SHA512 67e805f11b47d9bebd9a538aa775c109c81b6ab85b66cd479b7c8c0c222420cb5a5e30d993c04bd9b091ba457b3fb3673ff217ecf61feb40e189c60fa6d6c6d8
+DIST fonttools-4.47.0.gh.tar.gz 3810582 BLAKE2B a7821bca4507ba5638db537ba141bf7d1e2d5d23522f55766db0bc384ae366071e0848276285cff4056ffda513d94622f9b1154a43c2d8b341728790813b8124 SHA512 4a9a39b53248814dc2fcf648af5d7c8c79124a547d259571addb97c1e7181df7f20767baf5d2bb90f6c30790dd05c93c6bfac3281cedb91c73c45ad49039ee9b
diff --git a/dev-python/fonttools/fonttools-4.47.0.ebuild b/dev-python/fonttools/fonttools-4.47.0.ebuild
new file mode 100644
index 000000000000..640e8996304e
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.47.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}