summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-28 05:37:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-28 06:55:27 +0100
commit14fac63b3de2cb0e8310eb4e124bfcb89ea986ec (patch)
treeaf3a4a435c2f49d21014d5de36760d1a6946b63e
parentdev-python/botocore: Bump to 1.34.72 (diff)
downloadgentoo-14fac63b3de2cb0e8310eb4e124bfcb89ea986ec.tar.gz
gentoo-14fac63b3de2cb0e8310eb4e124bfcb89ea986ec.tar.bz2
gentoo-14fac63b3de2cb0e8310eb4e124bfcb89ea986ec.zip
dev-python/boto3: Bump to 1.34.72
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.72.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index fa58dd1db9c1..ce405c6af9b6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.64.gh.tar.gz 784663 BLAKE2B 6a4b335dba37ea09d7b2cec152699972b0b1
DIST boto3-1.34.69.gh.tar.gz 787293 BLAKE2B 9e46a959f3efdc3e673d38c8e3c30b8ceed1c1f47d685466e4164bcc1000381710bf8d8b6afff0999185ccddf38da591df004c54709729f2181308cb2279c43f SHA512 ef765518de95468e66270cea6dc93ede48547fb37db3ed9429659d85fb25174162cd062814c6adefeb8385c14079e7927f52d66501ab45f8d251ccfc830465e4
DIST boto3-1.34.70.gh.tar.gz 787964 BLAKE2B ae08d6acf82fcd038d8fe4a22c65a783d8d85df23c6b224668ee90edf5c7732b434ba8def604b91249e7fc529d15657edd7750e5a7777d96e9df94a637a5fdd1 SHA512 80497171abe3567649416f031e57538ce1fa8490998e038718b7f29ff2362e3f5de6f9b9ea86c0d0ccf9e5e49b5347e736ae086a17b7975175c0a7e89491ada1
DIST boto3-1.34.71.gh.tar.gz 788270 BLAKE2B adeb66e9ce793cec4a205942f2ed8b63fa859d9a7b407573d7cf49d9c96bc059e6a412c306f3125bd9fc1cc5ecfb6824697fbb4250e54a25abd3d32b8a2202fd SHA512 d75e784d42b634f32ac074d2c4c3760a21ef8d470d1637d5c0105e5832e475f68908c6cfc19ba20e7a562528bad1422654129a8d62c6c91b179adf1bc5c77268
+DIST boto3-1.34.72.gh.tar.gz 788630 BLAKE2B 8620116eae6daa8b147a62cb811281c0de89fbb759f1fc7a93d55568fb973de764c4d3ade2d246e1796f1e750406fda7bc318635ee8c25d3f59c574daf9deced SHA512 a84932a69f0718481ea3a00cc626f06de0d32f28bd404279a4b0655024fee9f8dc1d8105331fbb6d9049548c9adec05879207fd026cb652cc873b007ffba6f21
diff --git a/dev-python/boto3/boto3-1.34.72.ebuild b/dev-python/boto3/boto3-1.34.72.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.72.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}