summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 20:06:02 +0000
committerSam James <sam@gentoo.org>2021-04-25 20:07:39 +0000
commit1502e7cb49d8f09c4ca60c357545500884e24860 (patch)
tree4bcbf3be252f5baa70593b72b45a0686024c7a96
parentnet-p2p/go-ethereum: add 1.10.2 (diff)
downloadgentoo-1502e7cb.tar.gz
gentoo-1502e7cb.tar.bz2
gentoo-1502e7cb.zip
sys-apps/miller: add 5.10.2
Closes: https://bugs.gentoo.org/777708 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/miller/Manifest1
-rw-r--r--sys-apps/miller/miller-5.10.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/miller/Manifest b/sys-apps/miller/Manifest
index 59a024e51dca..8cf7fa7dc025 100644
--- a/sys-apps/miller/Manifest
+++ b/sys-apps/miller/Manifest
@@ -1,2 +1,3 @@
DIST miller-5.10.0.tar.gz 6793426 BLAKE2B 25ec96e29ee8d913feffd6e9a54cd2d494c9050e180556ed462a6d94a6adaaea88dbdbc09b4753f8888673bdc33a1f0aa43f9dac37bdc3c25191b2a565fe8847 SHA512 a7cbaee9ad4075d27e74ab3a60297164c535ea2bc1e38128174f4f226ad061850d37108e7d7547821b7e6667cb9a024639795d7678b1897fedf6ee15d6064538
DIST miller-5.10.1.tar.gz 6158587 BLAKE2B f22db3ccd29e0ff99e3f287e7e4382d679bba2c4d8e0fef3f3c086fa11ffbb287c22fc69c23f3baf647c2e5ac020d73f55ee613b0bb71273d7f94a5fe9561ea5 SHA512 32ec8216ea9c73c20b5c22fa047535c37f52a0d3c3c1100b090c57011cd555cae57a56425dfb0eaf0d09d41d82dbea3ad78a182ec8b538e194599b754f562961
+DIST miller-5.10.2.tar.gz 6192382 BLAKE2B 73daf0ca8a5417890e060b04103c4542f1122c13a9a13271dc53e94c4fdf0610dcad5ab04729326fd4ab72b47673db9fdf5aacc5a4ca5330c3220046e4d8a38b SHA512 be40611b055d94f3b0ef75b35dfd242dd4942dce3292bb01b48a6a12f9e4c09fc43bb9d0650902c7aa13328d9a2bbcea4da2964af58d07f39ae63b34712a45f5
diff --git a/sys-apps/miller/miller-5.10.2.ebuild b/sys-apps/miller/miller-5.10.2.ebuild
new file mode 100644
index 000000000000..b164bf5ed1ee
--- /dev/null
+++ b/sys-apps/miller/miller-5.10.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A tool like sed, awk, cut, join, and sort for name-indexed data (CSV, JSON, ..)"
+HOMEPAGE="https://johnkerl.org/miller/doc/index.html"
+SRC_URI="https://github.com/johnkerl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+
+ # Respect flags
+ find -type f -name "Makefile.am" -exec sed -i -r -e '/.*FLAGS[^=]*=/ s:(-g|-pg|-O[0-9]) ::g' -- {} \; || die
+
+ # Disable docs rebuilding as they're shipped prebuilt
+ sed -e '/SUBDIRS[^=]*=/ s:doc::g' -i -- Makefile.am || die
+
+ # Disable building tests automagically
+ if ! use test; then
+ sed -e '/SUBDIRS[^=]*=/ s:[^ ]*_test::g' -i -- c/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_test() {
+ emake -C c/reg_test
+ emake -C c/unit_test
+}
+
+src_install() {
+ local HTML_DOCS=( $(usex doc docs) )
+
+ default
+
+ doman docs/mlr.1
+}