summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-04 17:18:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-04 18:34:04 +0200
commit15038afd179e38a4fb4554674ae0b727ed0cb377 (patch)
treed3aca81e7d32c177882dcd661c91c0304900fa4f
parentmedia-tv/mythtv: Drop obsolete 31.0-r1 (diff)
downloadgentoo-15038afd.tar.gz
gentoo-15038afd.tar.bz2
gentoo-15038afd.zip
media-libs/libsamplerate: EAPI-7 bump, drop static-libs, sync ~s390
s390 keyword was added in commit 1bd8d2c143682696feba5f0c50cff4d35e8ab122. Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libsamplerate/libsamplerate-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/media-libs/libsamplerate/libsamplerate-9999.ebuild b/media-libs/libsamplerate/libsamplerate-9999.ebuild
index 99d01539ddca..b763d7394fb2 100644
--- a/media-libs/libsamplerate/libsamplerate-9999.ebuild
+++ b/media-libs/libsamplerate/libsamplerate-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit multilib-minimal
@@ -13,12 +13,12 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/erikd/libsamplerate.git"
else
SRC_URI="http://www.mega-nerd.com/SRC/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
fi
LICENSE="BSD-2"
SLOT="0"
-IUSE="static-libs test"
+IUSE="test"
RESTRICT="!test? ( test )"
# Alsa/FFTW are only required for tests
@@ -29,25 +29,25 @@ DEPEND="
media-libs/libsndfile[${MULTILIB_USEDEP}]
sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
)
- virtual/pkgconfig"
+"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
-
[[ ${PV} == *9999 ]] && eautoreconf
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static) \
- $(use_enable test alsa) \
- $(use_enable test fftw) \
+ local myeconfargs=(
+ --disable-static
+ $(use_enable test alsa)
+ $(use_enable test fftw)
$(use_enable test sndfile)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}