summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-06-24 21:11:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-06-24 21:11:32 +0100
commit15146545b8770900b9323a0ff5a18b2eee4ee265 (patch)
tree212bb0550265ac8a2523d20e0f5ed98690ba1d89
parentgames-fps/freedm: Add games-fps/prboom-plus to the dependency list (diff)
downloadgentoo-15146545b8770900b9323a0ff5a18b2eee4ee265.tar.gz
gentoo-15146545b8770900b9323a0ff5a18b2eee4ee265.tar.bz2
gentoo-15146545b8770900b9323a0ff5a18b2eee4ee265.zip
games-fps/prboom: prboom is dead, long live prboom-plus!
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-fps/prboom/Manifest2
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-libpng14.patch22
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-nvidia-test.c3
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-nvidia.patch48
-rw-r--r--games-fps/prboom/metadata.xml11
-rw-r--r--games-fps/prboom/prboom-2.5.0-r1.ebuild91
-rw-r--r--profiles/updates/2Q-20191
7 files changed, 1 insertions, 177 deletions
diff --git a/games-fps/prboom/Manifest b/games-fps/prboom/Manifest
deleted file mode 100644
index 44e5df82a2be..000000000000
--- a/games-fps/prboom/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST prboom-2.5.0.tar.gz 1049505 BLAKE2B eb044c091279e04bfb65f9fea26bb706be213510b82a95ebe9d482a7c5d2c2ca5a51776afb3af6e8cebeba5df2441922f2298e52c54414b56e98e637c6feb544 SHA512 9e25b55047c66931ea010751fb64484e466395b04dfb738ed9dc515bd8b78e1124a337da33bf7be6e97280016ed1f01c852d8bc12704bdb82074488d7b5d2894
-DIST prboom.png 4254 BLAKE2B cf70f0ee9d41ad41c3f326b30a12df90f76fdb788d252b29bce1925ef253ec272feedc7040a8bf33146f313517afdc038c66324b9c671d90a7db89a5da2569db SHA512 72631d253c6754484ab1c96c953ed37a734197fa851dc88156fd3d4fb8396a77347805233481470b936a504d08e06d994de1eba613e6bf70a89db8fc7ee9b1ac
diff --git a/games-fps/prboom/files/prboom-2.5.0-libpng14.patch b/games-fps/prboom/files/prboom-2.5.0-libpng14.patch
deleted file mode 100644
index 3dea0e7a983b..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-libpng14.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=308739
-
---- a/src/SDL/i_sshot.c
-+++ b/src/SDL/i_sshot.c
-@@ -231,7 +231,7 @@
- if (fp)
- {
- png_struct *png_ptr = png_create_write_struct(
-- PNG_LIBPNG_VER_STRING, png_error_ptr_NULL, error_fn, warning_fn);
-+ PNG_LIBPNG_VER_STRING, NULL, error_fn, warning_fn);
-
- if (png_ptr)
- {
-@@ -279,7 +279,7 @@
- break;
- }
- }
-- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
-+ png_destroy_write_struct(&png_ptr, NULL);
- }
- fclose(fp);
- }
diff --git a/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c b/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c
deleted file mode 100644
index f9e4bd700f8a..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c
+++ /dev/null
@@ -1,3 +0,0 @@
-#include <SDL/SDL_opengl.h>
-PFNGLCOLORTABLEEXTPROC glColorTableEXT;
-int main(){return 0;}
diff --git a/games-fps/prboom/files/prboom-2.5.0-nvidia.patch b/games-fps/prboom/files/prboom-2.5.0-nvidia.patch
deleted file mode 100644
index c602c784c13f..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-nvidia.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/src/gl_intern.h.orig 2003-09-21 16:39:30.247451624 -0400
-+++ b/src/gl_intern.h 2003-09-21 16:39:41.610724144 -0400
-@@ -84,6 +84,6 @@
- #define min(a,b) ((a)<(b)?(a):(b))
- #endif
-
--PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
-+//PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
-
- #endif // _GL_INTERN_H
---- a/src/gl_main.c.orig 2003-09-21 16:39:55.436622288 -0400
-+++ b/src/gl_main.c 2003-09-21 16:43:00.943420968 -0400
-@@ -285,6 +285,7 @@
-
- if (strcasecmp(extension, "GL_EXT_texture_filter_anisotropic") == 0)
- gl_texture_filter_anisotropic = true;
-+/*
- else if (strcasecmp(extension, "GL_EXT_paletted_texture") == 0) {
- if (gl_use_paletted_texture) {
- gl_paletted_texture = true;
-@@ -304,6 +305,7 @@
- else
- lprintf(LO_INFO,"using GL_EXT_shared_texture_palette\n",glGetString(GL_VENDOR));
- }
-+*/
-
- extension = p;
- } while (*extension != '\0');
-@@ -761,7 +763,7 @@
- pal[transparent_pal_index*4+1]=0;
- pal[transparent_pal_index*4+2]=0;
- pal[transparent_pal_index*4+3]=0;
-- gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
-+// gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
- W_UnlockLumpName("PLAYPAL");
- } else {
- if (palette>0)
---- a/src/gl_texture.c.orig 2003-09-21 16:43:18.450759448 -0400
-+++ b/src/gl_texture.c 2003-09-21 16:43:39.549551944 -0400
-@@ -178,7 +178,7 @@
- pal[transparent_pal_index*4+1]=0;
- pal[transparent_pal_index*4+2]=0;
- pal[transparent_pal_index*4+3]=0;
-- gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
-+// gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
- W_UnlockLumpName("PLAYPAL");
- }
-
diff --git a/games-fps/prboom/metadata.xml b/games-fps/prboom/metadata.xml
deleted file mode 100644
index 55dd7e52946f..000000000000
--- a/games-fps/prboom/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">prboom</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-fps/prboom/prboom-2.5.0-r1.ebuild b/games-fps/prboom/prboom-2.5.0-r1.ebuild
deleted file mode 100644
index 9cb1017bc0a2..000000000000
--- a/games-fps/prboom/prboom-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit desktop readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Port of ID's doom to SDL and OpenGL"
-HOMEPAGE="http://prboom.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RDEPEND="
- media-libs/libsdl[joystick,video]
- media-libs/sdl-mixer
- media-libs/sdl-net
- !<games-fps/lsdldoom-1.5
- virtual/opengl
- virtual/glu
-"
-DEPEND="${RDEPEND}"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-To play the original Doom levels, place doom.wad and/or doom2.wad
-into /usr/share/doom-data
-Then run ${PN} accordingly.
-
-doom1.wad is the shareware demo wad consisting of 1 episode,
-and doom.wad is the full Doom 1 set of 3 episodes
-(or 4 in the Ultimate Doom wad).
-
-You can even emerge doom-data and/or freedoom to play for free.
-"
-
-src_prepare() {
- default
-
- ebegin "Detecting NVidia GL/prboom bug"
- $(tc-getCC) "${FILESDIR}"/${P}-nvidia-test.c 2> /dev/null
- local ret=$?
- eend ${ret} "NVidia GL/prboom bug found ;("
- [ ${ret} -eq 0 ] || eapply "${FILESDIR}"/${P}-nvidia.patch
-
- eapply "${FILESDIR}"/${P}-libpng14.patch
-
- sed -i \
- -e '/^gamesdir/ s/\/games/\/bin/' \
- src/Makefile.in \
- || die "sed failed"
- sed -i \
- -e 's/: install-docDATA/:/' \
- -e '/^SUBDIRS/ s/doc//' \
- Makefile.in \
- || die "sed failed"
- sed -i \
- -e 's:-ffast-math $CFLAGS_OPT::' \
- configure \
- || die "sed configure failed"
-}
-
-src_configure() {
- # leave --disable-cpu-opt in otherwise the configure script
- # will append -march=i686 and crap ... let the user's CFLAGS
- # handle this ...
- econf \
- --enable-gl \
- --disable-i386-asm \
- --disable-cpu-opt \
- --with-waddir="/usr/share/doom-data"
-}
-
-src_install() {
- default
-
- doman doc/*.{5,6}
-
- dodoc doc/README.* doc/*.txt
- readme.gentoo_create_doc
-
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} "PrBoom"
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/profiles/updates/2Q-2019 b/profiles/updates/2Q-2019
index beb3d93bac28..7e275607af8f 100644
--- a/profiles/updates/2Q-2019
+++ b/profiles/updates/2Q-2019
@@ -1,2 +1,3 @@
move net-nds/gss-proxy net-nds/gssproxy
move app-emacs/anything app-emacs/helm
+move games-fps/prboom games-fps/prboom-plus