summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-02 21:41:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-02 22:15:23 +0300
commit15395cf92796525b358e3fe20621a292cbfe1da7 (patch)
tree7f12156e9281c4b31f8abfb3c9feae4754f5268a
parenteclass/java-utils-2.eclass: drop gnu-classpath (diff)
downloadgentoo-15395cf9.tar.gz
gentoo-15395cf9.tar.bz2
gentoo-15395cf9.zip
dev-python/stomp-py: add 8.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/stomp-py/Manifest1
-rw-r--r--dev-python/stomp-py/stomp-py-8.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index 612c26af9fc0..b0efe4826ac1 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1 +1,2 @@
DIST stomp.py-8.0.0.tar.gz 35146 BLAKE2B 65f15e0145e1fc48d4f9ccf37ce81f1f7464e9179d63d6f22e96dd99ce35692dbcb6056730c35255428b0ccf0d744debc39e2c12e6e2b6675ac20c7ec0ff3efd SHA512 068694e9bc42e45dd769275296a1ea817153cb0318b08377be5e0b9563989a83bff35c4bc424e00939b7521938aa34f485401f07a8a51c3d9a90eea3f00c1ea1
+DIST stomp.py-8.0.1.tar.gz 35300 BLAKE2B 12209e99066fb5bb1f3015398f5eb27186322ce9d92feca46adc4d275aff1d5138908da69abe3be512325bd30a3a21773886ba5fa21917c71d13bc53b0977de4 SHA512 009189cd07c379641c9fa3b3af1df70c9e26b77bbb6d2443a78b56ff9895b4382e90a753db83f4a863fae5ef5765c660d2f82ef14ab6e74817bc83e7ea8ba6d3
diff --git a/dev-python/stomp-py/stomp-py-8.0.1.ebuild b/dev-python/stomp-py/stomp-py-8.0.1.ebuild
new file mode 100644
index 000000000000..9b841f321106
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"