summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-10-05 18:55:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-10-05 18:56:15 -0500
commit153b93bf660f8360d82beeb9a2ed92532a522e9f (patch)
treea9dd379407fa1505599cfbc1f43ce1d2fbe04cbc
parentapp-crypt/acme: add 1.31.0 (diff)
downloadgentoo-153b93bf660f8360d82beeb9a2ed92532a522e9f.tar.gz
gentoo-153b93bf660f8360d82beeb9a2ed92532a522e9f.tar.bz2
gentoo-153b93bf660f8360d82beeb9a2ed92532a522e9f.zip
app-crypt/certbot: add 1.31.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-1.31.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 8ae96f64bfb0..4374c9ab7fd6 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.29.0.tar.gz 1367853 BLAKE2B c0d8d2c05a061b2d50564a97bf17ae883bd443321bf99cea13fbae196c7ec876231d803d5389e524997dd8632035d5ad60b1a99b025a22a65d0865d564cfafc5 SHA512 755781e12e0e4cdb41aa16d90ab6a334ef41a98630e08127a867c8e8813ee45ebd3f6f54168fe747900f6ab59539e414ffed7891c05746b3a7af2e2a96a8d522
DIST certbot-1.30.0.tar.gz 1370072 BLAKE2B c9286bc6dfee59c5a7b458430b08ee273615b42e40d2355b41c5d58a0b8757d83551e947058660e4abda88d7f11c16184a248c313b4d01e145df0e39b717bf86 SHA512 15727a7a38a9cbe4890a347c0cc2a795be19502ece28034400d41cf96a6d4bef197890bd85cd02ecc6a792e3502ae8aa663aad45e980047567f0d3b161cbe3df
+DIST certbot-1.31.0.tar.gz 1371459 BLAKE2B 95fc9f29b1e91f5bc12a9b7146d00f4f3b4647eeda8e866c46c17d8d8a2443bd46cfa04758e8571e84b2bbf70bd68943c47ceaf6d830d3e5121e41d9548da051 SHA512 a2f6d7714bfc8e2c400e69be038404da138b53f0dc09e071048d560ba9e9527cc0b786b8d210b62c3d07c3aeadaee12dc0d060d144af4b5c3178576fde65b052
diff --git a/app-crypt/certbot/certbot-1.31.0.ebuild b/app-crypt/certbot/certbot-1.31.0.ebuild
new file mode 100644
index 000000000000..3d098ba0560b
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.31.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )"
+
+distutils_enable_tests pytest