summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-30 04:03:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-30 04:46:12 +0200
commit1563970f8159d7d49b1a44c40f370f08f10d383d (patch)
treeb2b0bcc0678b758830bbcceaae2b9215449e2b91
parentapp-admin/awscli: Bump to 1.27.164 (diff)
downloadgentoo-1563970f8159d7d49b1a44c40f370f08f10d383d.tar.gz
gentoo-1563970f8159d7d49b1a44c40f370f08f10d383d.tar.bz2
gentoo-1563970f8159d7d49b1a44c40f370f08f10d383d.zip
dev-util/stripe-mock: Bump to 0.165.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.165.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index b85c2811b06c..9497abe7a971 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.164.0.tar.gz 1249727 BLAKE2B fda30a53eda51b9e001024c3dad9ae3bf0922ce9892a0e43a63f3a29f477acbc7f4b83d4af90c47ee9f78696a3fa97f051910f4ba005a5de72ef5cad48d9ed0c SHA512 3221f05e548252069797bad5d6a0413c3c0b26c033572fc55cf37bdf2a1e560f8f69de20c32260eca841feef0cae51e32335c2ae4264d7c141ebd9ec67f02519
+DIST stripe-mock-0.165.0.tar.gz 1274806 BLAKE2B 9f0cdcba97f3c6755cd04061cf6a6f9122d18eb6ecc3ef975e2e3be93c191eb6a3ba0c3d696485eaa0d4021284305f0c79ab0f67049cfba08ec2ba21abf47888 SHA512 12a2004e543de5a6e789d894bc07fe8bbb011447e4ca4c842a8f7e5b9ca063c70a1d1b93fe033fad6beabe7fc6c30f19cd9e6d7eb64677844f48096dd59c73e1
diff --git a/dev-util/stripe-mock/stripe-mock-0.165.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.165.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.165.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}