summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-21 10:32:45 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 11:15:27 +0200
commit15651dfcbe2782dde809a805ddbc37f6cab9eb23 (patch)
tree82d587490df16208a4ef6779b75db1e2411381f8
parentdev-ml/llvm-ocaml: Reorder ebuild vars in 9+ (diff)
downloadgentoo-15651dfc.tar.gz
gentoo-15651dfc.tar.bz2
gentoo-15651dfc.zip
dev-python/clang-python: Reorder ebuild vars in 9+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/clang-python/clang-python-10.0.0.9999.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-9.0.0.9999.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-9.0.0.ebuild5
3 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
index ce6a903df4ab..5a65d445f01f 100644
--- a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
@@ -9,6 +9,8 @@ inherit git-r3 python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+S=${WORKDIR}/${P}/bindings/python
+
EGIT_REPO_URI="https://git.llvm.org/git/clang.git
https://github.com/llvm-mirror/clang.git"
@@ -16,8 +18,8 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
@@ -28,8 +30,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${P}/bindings/python
-
src_unpack() {
git-r3_fetch
git-r3_checkout '' '' '' bindings/python
diff --git a/dev-python/clang-python/clang-python-9.0.0.9999.ebuild b/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
index 70de2ed55129..d1c47b42ebfc 100644
--- a/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
@@ -9,6 +9,8 @@ inherit git-r3 python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+S=${WORKDIR}/${P}/bindings/python
+
EGIT_REPO_URI="https://git.llvm.org/git/clang.git
https://github.com/llvm-mirror/clang.git"
EGIT_BRANCH="release_90"
@@ -17,8 +19,8 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
@@ -29,8 +31,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${P}/bindings/python
-
src_unpack() {
git-r3_fetch
git-r3_checkout '' '' '' bindings/python
diff --git a/dev-python/clang-python/clang-python-9.0.0.ebuild b/dev-python/clang-python/clang-python-9.0.0.ebuild
index 6583d35ad131..63f0e576f048 100644
--- a/dev-python/clang-python/clang-python-9.0.0.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.0.ebuild
@@ -10,13 +10,14 @@ MY_P=cfe-${PV/_/}.src
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}/bindings/python
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-fbsd"
IUSE="test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
@@ -27,8 +28,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}/bindings/python
-
src_unpack() {
einfo "Unpacking parts of ${MY_P}.tar.xz ..."
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die