summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-22 11:56:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-22 11:56:37 +0100
commit157b9faad2181f91f886afe744c11a7f49b2666b (patch)
treea2c621850bcbde6d0fa181eab2b7f2104ad553f6
parentdev-python/warlock: Switch to PEP517 build (diff)
downloadgentoo-157b9faad2181f91f886afe744c11a7f49b2666b.tar.gz
gentoo-157b9faad2181f91f886afe744c11a7f49b2666b.tar.bz2
gentoo-157b9faad2181f91f886afe744c11a7f49b2666b.zip
dev-python/jsonschema: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/files/jsonschema-3.2.0-add-webcolors-1.11-compat.patch70
-rw-r--r--dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild44
3 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 2da6195da3f1..922228fe4ff7 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,2 @@
-DIST jsonschema-3.2.0.tar.gz 167226 BLAKE2B f89a8198f6b7b4dd56b0320ddecdd834423cbeaf49fbbd1563007da61004322b92e25856ecc17b4d02e2162b2359ec5d7601826fe42cfcb7683ae16cf2baeb39 SHA512 acbb4cec730a8cdab9f070593ed896064fbe082d464ec362adc952e4985e9eaa12ad0f2d55a04018ffdaf675e54037999a7219533dad6b84bf609f5dfe21bbab
DIST jsonschema-4.3.3.tar.gz 311720 BLAKE2B 685e7712bdf87f0b6cfdc0ca6b094c90efd78acec72a6233661caddbba52e55ab78af83a24b14b9580a9eed6179302208b35ca836dce36459db65f0017805142 SHA512 f2a9e4d89a12d5d1c53666a9c95bc29adf2559438f0ab11f34abaf3f2525f525cd742ae54f2d3a732d98db92c4f45fc7611ffbc61f2ac1121377066a86db3bf9
DIST jsonschema-4.4.0.tar.gz 313519 BLAKE2B 6339c4ac9e99b55e41c133861baacb6644e04d15e915d3199955512530c946973ca6d5348746688660ea7392d53102754dba3f3380fc8aa3a4ab284a9dcde684 SHA512 8e5c138f4debf7540e2cd131f3f208d1778927ac9036f5fa67bcf5db8c62fe1bb454c7818ee61acef64e856ea4b498ef6ab08be314a3c6b1e461e0bb44db41c7
diff --git a/dev-python/jsonschema/files/jsonschema-3.2.0-add-webcolors-1.11-compat.patch b/dev-python/jsonschema/files/jsonschema-3.2.0-add-webcolors-1.11-compat.patch
deleted file mode 100644
index bfb4fa8d139b..000000000000
--- a/dev-python/jsonschema/files/jsonschema-3.2.0-add-webcolors-1.11-compat.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 09595a50f507399bf3fa8c68ed6371c42b9c4874 Mon Sep 17 00:00:00 2001
-From: Julian Berman <Julian@GrayVines.com>
-Date: Fri, 21 Feb 2020 09:30:05 -0500
-Subject: [PATCH 1/2] Newer webcolors has a new API apparently.
-
----
- jsonschema/_format.py | 2 +-
- setup.cfg | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/jsonschema/_format.py b/jsonschema/_format.py
-index 281a7cf..f3c758c 100644
---- a/jsonschema/_format.py
-+++ b/jsonschema/_format.py
-@@ -354,7 +354,7 @@ else:
- def is_css21_color(instance):
- if (
- not isinstance(instance, str_types) or
-- instance.lower() in webcolors.css21_names_to_hex
-+ instance.lower() in webcolors.CSS21_NAMES_TO_HEX
- ):
- return True
- return is_css_color_code(instance)
---
-2.24.1
-
-From 0d192e192526252c30c16b3651c293bb5f21a99f Mon Sep 17 00:00:00 2001
-From: Julian Berman <Julian@GrayVines.com>
-Date: Fri, 21 Feb 2020 09:56:13 -0500
-Subject: [PATCH 2/2] Sigh... but also drops Py2 compat.
-
----
- jsonschema/_format.py | 11 ++++++++---
- setup.cfg | 4 ++--
- 2 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/jsonschema/_format.py b/jsonschema/_format.py
-index f3c758c..b96efb6 100644
---- a/jsonschema/_format.py
-+++ b/jsonschema/_format.py
-@@ -342,10 +342,15 @@ def is_draft3_time(instance):
- return datetime.datetime.strptime(instance, "%H:%M:%S")
-
-
--try:
-+try: # webcolors>=1.11
-+ from webcolors import CSS21_NAMES_TO_HEX
- import webcolors
- except ImportError:
-- pass
-+ try: # webcolors<1.11
-+ from webcolors import css21_names_to_hex as CSS21_NAMES_TO_HEX
-+ import webcolors
-+ except ImportError:
-+ pass
- else:
- def is_css_color_code(instance):
- return webcolors.normalize_hex(instance)
-@@ -354,7 +359,7 @@ else:
- def is_css21_color(instance):
- if (
- not isinstance(instance, str_types) or
-- instance.lower() in webcolors.CSS21_NAMES_TO_HEX
-+ instance.lower() in CSS21_NAMES_TO_HEX
- ):
- return True
- return is_css_color_code(instance)
---
-2.24.1
-
diff --git a/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild b/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild
deleted file mode 100644
index a1a69cca3a4a..000000000000
--- a/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- test? ( dev-python/twisted[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="${BDEPEND}
- dev-python/idna[${PYTHON_USEDEP}]
- >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webcolors[${PYTHON_USEDEP}]
- dev-python/rfc3986-validator[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
-"
-
-BDEPEND+="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-add-webcolors-1.11-compat.patch
-)
-
-distutils_enable_tests unittest