summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-26 08:31:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-08-14 14:37:35 +0300
commit1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0 (patch)
tree17d8e33d72893093c945787c317cf0a35182e522
parentnet-im/telegram-desktop-bin: add 4.8.9 (diff)
downloadgentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.tar.gz
gentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.tar.bz2
gentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.zip
games-engines/openmw: enable lua5-1, lua5-3, lua5-4
But only on arches which don't support luajit Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-engines/openmw/openmw-0.48.0.ebuild10
-rw-r--r--games-engines/openmw/openmw-9999.ebuild10
-rw-r--r--profiles/arch/powerpc/ppc64/package.use.force7
-rw-r--r--profiles/arch/powerpc/ppc64/package.use.mask8
-rw-r--r--profiles/base/package.use.force7
-rw-r--r--profiles/base/package.use.mask8
6 files changed, 44 insertions, 6 deletions
diff --git a/games-engines/openmw/openmw-0.48.0.ebuild b/games-engines/openmw/openmw-0.48.0.ebuild
index a7b997f5b8a9..53fd00d2a2fe 100644
--- a/games-engines/openmw/openmw-0.48.0.ebuild
+++ b/games-engines/openmw/openmw-0.48.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-LUA_COMPAT=( luajit )
+LUA_COMPAT=( lua5-{1,3,4} luajit )
inherit cmake lua-single readme.gentoo-r1 xdg
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
@@ -105,8 +105,6 @@ src_configure() {
-DUSE_LUAJIT=ON
)
else
- # 5.1 (and other 5.x) are supported in theory, but don't work well (eg. test fails)
- # In a future version consider adding it back to LUA_COMPAT or dropping this branch
mycmakeargs+=(
-DUSE_LUAJIT=OFF
-DLua_FIND_VERSION_MAJOR=$(ver_cut 1 $(lua_get_version))
@@ -137,6 +135,12 @@ src_compile() {
}
src_test() {
+ # Lua 5.x is supported in theory, but don't work as well, the test fails
+ # Upstream recommends luajit, but it has less arch coverage
+ if [[ ${ELUA} != luajit ]]; then
+ elog "Skipping tests on ${ELUA}"
+ return
+ fi
pushd "${BUILD_DIR}" > /dev/null || die
./openmw_test_suite || die
popd > /dev/null || die
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index a7b997f5b8a9..53fd00d2a2fe 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-LUA_COMPAT=( luajit )
+LUA_COMPAT=( lua5-{1,3,4} luajit )
inherit cmake lua-single readme.gentoo-r1 xdg
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
@@ -105,8 +105,6 @@ src_configure() {
-DUSE_LUAJIT=ON
)
else
- # 5.1 (and other 5.x) are supported in theory, but don't work well (eg. test fails)
- # In a future version consider adding it back to LUA_COMPAT or dropping this branch
mycmakeargs+=(
-DUSE_LUAJIT=OFF
-DLua_FIND_VERSION_MAJOR=$(ver_cut 1 $(lua_get_version))
@@ -137,6 +135,12 @@ src_compile() {
}
src_test() {
+ # Lua 5.x is supported in theory, but don't work as well, the test fails
+ # Upstream recommends luajit, but it has less arch coverage
+ if [[ ${ELUA} != luajit ]]; then
+ elog "Skipping tests on ${ELUA}"
+ return
+ fi
pushd "${BUILD_DIR}" > /dev/null || die
./openmw_test_suite || die
popd > /dev/null || die
diff --git a/profiles/arch/powerpc/ppc64/package.use.force b/profiles/arch/powerpc/ppc64/package.use.force
index 6f146360a178..392d82d7563d 100644
--- a/profiles/arch/powerpc/ppc64/package.use.force
+++ b/profiles/arch/powerpc/ppc64/package.use.force
@@ -1,6 +1,13 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Alexey Sokolov <alexey+gentoo@asokolov.org> (2023-08-14)
+# OpenMW is only playtested with LuaJIT, and in fact unit tests fail with Lua-5.
+# Therefore apply mask/force to override the profile's defaults, and invert on
+# arches where luajit is not keyworded.
+# Done this way also avoids conflicts for users using another default.
+games-engines/openmw -lua_single_target_luajit
+
# Ionen Wolkens <ionen@gentoo.org> (2023-07-26)
# MPV currently[1] has no plans to support >=lua5-3 making luajit
# the only choice for maintained lua. Apply mask/force to override
diff --git a/profiles/arch/powerpc/ppc64/package.use.mask b/profiles/arch/powerpc/ppc64/package.use.mask
index 024cd7c1512a..8cc8e18bc464 100644
--- a/profiles/arch/powerpc/ppc64/package.use.mask
+++ b/profiles/arch/powerpc/ppc64/package.use.mask
@@ -1,6 +1,14 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Alexey Sokolov <alexey+gentoo@asokolov.org> (2023-08-14)
+# OpenMW is only playtested with LuaJIT, and in fact unit tests fail with Lua-5.
+# Therefore apply mask/force to override the profile's defaults, and invert on
+# arches where luajit is not keyworded.
+# Done this way also avoids conflicts for users using another default.
+games-engines/openmw -lua_single_target_lua5-1 lua_single_target_luajit
+games-engines/openmw -lua_single_target_lua5-3 -lua_single_target_lua5-4
+
# Ionen Wolkens <ionen@gentoo.org> (2023-07-26)
# MPV currently[1] has no plans to support >=lua5-3 making luajit
# the only choice for maintained lua. Apply mask/force to override
diff --git a/profiles/base/package.use.force b/profiles/base/package.use.force
index ed168436b9e2..e1cab4651ef9 100644
--- a/profiles/base/package.use.force
+++ b/profiles/base/package.use.force
@@ -1,6 +1,13 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Alexey Sokolov <alexey+gentoo@asokolov.org> (2023-08-14)
+# OpenMW is only playtested with LuaJIT, and in fact unit tests fail with Lua-5.
+# Therefore apply mask/force to override the profile's defaults, and invert on
+# arches where luajit is not keyworded.
+# Done this way also avoids conflicts for users using another default.
+games-engines/openmw lua_single_target_luajit
+
# Ionen Wolkens <ionen@gentoo.org> (2023-07-26)
# MPV currently[1] has no plans to support >=lua5-3 making luajit
# the only choice for maintained lua. Apply mask/force to override
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 4cceebbdd213..14d383b0a158 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -18,6 +18,14 @@ sci-geosciences/mapserver php
# php-7.x is End-of-Life (EOL) and masked.
www-servers/nginx-unit php7-4
+# Alexey Sokolov <alexey+gentoo@asokolov.org> (2023-08-14)
+# OpenMW is only playtested with LuaJIT, and in fact unit tests fail with Lua-5.
+# Therefore apply mask/force to override the profile's defaults, and invert on
+# arches where luajit is not keyworded.
+# Done this way also avoids conflicts for users using another default.
+games-engines/openmw lua_single_target_lua5-1
+games-engines/openmw lua_single_target_lua5-3 lua_single_target_lua5-4
+
# Ionen Wolkens <ionen@gentoo.org> (2023-07-26)
# MPV currently[1] has no plans to support >=lua5-3 making luajit
# the only choice for maintained lua. Apply mask/force to override