summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-06 10:05:49 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-06 10:08:42 +0200
commit158a78e01498a6d92a353da0e9a3b58a6a3ca93d (patch)
tree0b09da85324be00e457cfe53a749a2db87cf205a
parentdev-java/univocity-parsers: Import from junit-5-ebuild-repo (diff)
downloadgentoo-158a78e01498a6d92a353da0e9a3b58a6a3ca93d.tar.gz
gentoo-158a78e01498a6d92a353da0e9a3b58a6a3ca93d.tar.bz2
gentoo-158a78e01498a6d92a353da0e9a3b58a6a3ca93d.zip
app-emacs/gnuserv: Fix byte-compilation with Emacs 28
Update HOMEPAGE and SRC_URI. Closes: https://bugs.gentoo.org/836892 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/gnuserv/files/gnuserv-3.12.8-emacs-28.patch36
-rw-r--r--app-emacs/gnuserv/files/gnuserv-3.12.8-gnudoit.patch15
-rw-r--r--app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild18
3 files changed, 60 insertions, 9 deletions
diff --git a/app-emacs/gnuserv/files/gnuserv-3.12.8-emacs-28.patch b/app-emacs/gnuserv/files/gnuserv-3.12.8-emacs-28.patch
new file mode 100644
index 000000000000..dde9fdc38043
--- /dev/null
+++ b/app-emacs/gnuserv/files/gnuserv-3.12.8-emacs-28.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/836892
+
+--- gnuserv-3.12.8/gnuserv.el
++++ gnuserv-3.12.8/gnuserv.el
+@@ -98,31 +98,6 @@
+ :group 'gnuserv)
+
+
+-;; Provide the old variables as aliases, to avoid breaking .emacs
+-;; files. However, they are obsolete and should be converted to the
+-;; new forms. This ugly crock must be before the variable
+-;; declaration, or the scheme fails.
+-
+-(define-obsolete-variable-alias 'server-frame 'gnuserv-frame)
+-(define-obsolete-variable-alias 'server-done-function
+- 'gnuserv-done-function)
+-(define-obsolete-variable-alias 'server-done-temp-file-function
+- 'gnuserv-done-temp-file-function)
+-(define-obsolete-variable-alias 'server-find-file-function
+- 'gnuserv-find-file-function)
+-(define-obsolete-variable-alias 'server-program
+- 'gnuserv-program)
+-(define-obsolete-variable-alias 'server-visit-hook
+- 'gnuserv-visit-hook)
+-(define-obsolete-variable-alias 'server-done-hook
+- 'gnuserv-done-hook)
+-(define-obsolete-variable-alias 'server-kill-quietly
+- 'gnuserv-kill-quietly)
+-(define-obsolete-variable-alias 'server-temp-file-regexp
+- 'gnuserv-temp-file-regexp)
+-(define-obsolete-variable-alias 'server-make-temp-file-backup
+- 'gnuserv-make-temp-file-backup)
+-
+ ;;;###autoload
+ (defcustom gnuserv-frame nil
+ "*The frame to be used to display all edited files.
diff --git a/app-emacs/gnuserv/files/gnuserv-3.12.8-gnudoit.patch b/app-emacs/gnuserv/files/gnuserv-3.12.8-gnudoit.patch
new file mode 100644
index 000000000000..bcb0fdeeaecc
--- /dev/null
+++ b/app-emacs/gnuserv/files/gnuserv-3.12.8-gnudoit.patch
@@ -0,0 +1,15 @@
+--- gnuserv-3.12.8/gnudoit
++++ gnuserv-3.12.8/gnudoit
+@@ -27,10 +27,10 @@
+
+ if [ $# -eq 0 ]
+ then
+- exec gnuclient $quick -batch
++ exec gnuclient-emacs $quick -batch
+ else
+ # I use "$*" instead of "$@" intentionally -- I don't want to have the
+ # arguments split.
+- exec gnuclient $quick -batch -eval "$*"
++ exec gnuclient-emacs $quick -batch -eval "$*"
+ fi
+
diff --git a/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild b/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
index fdd9b4a6d7ca..8c147acf559b 100644
--- a/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
+++ b/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
@@ -6,8 +6,9 @@ EAPI=7
inherit elisp desktop xdg-utils
DESCRIPTION="Attach to an already running Emacs"
-HOMEPAGE="http://meltin.net/hacks/emacs/"
-SRC_URI="http://meltin.net/hacks/emacs/src/${P}.tar.gz"
+HOMEPAGE="https://web.archive.org/web/20160508134736/http://martin.meltin.net/hacks/emacs/
+ https://www.emacswiki.org/emacs/GnuClient"
+SRC_URI="https://web.archive.org/web/20150908031821/http://martin.meltin.net/sites/martin.meltin.net/files/hacks/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -19,15 +20,14 @@ RDEPEND=">=app-eselect/eselect-emacs-1.15
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
+PATCHES=(
+ "${FILESDIR}"/${P}-backquotes.patch
+ "${FILESDIR}"/${P}-process-query.patch
+ "${FILESDIR}"/${P}-gnudoit.patch
+ "${FILESDIR}"/${P}-emacs-28.patch
+)
SITEFILE="50${PN}-gentoo.el"
-src_prepare() {
- eapply "${FILESDIR}"/${P}-backquotes.patch
- eapply "${FILESDIR}"/${P}-process-query.patch
- sed -i -e 's/exec gnuclient/&-emacs/' gnudoit || die
- eapply_user
-}
-
src_configure() {
econf $(use_enable X xauth) \
--x-includes="${EPREFIX}"/usr/include \