summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 16:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 18:09:22 +0200
commit158eb9410e0a9b325002840a3168454675ed0cd6 (patch)
treecee952aeee09197fb001eec53ab0e99693e9c437
parentdev-python/guessit: Take it back to python@ (diff)
downloadgentoo-158eb9410e0a9b325002840a3168454675ed0cd6.tar.gz
gentoo-158eb9410e0a9b325002840a3168454675ed0cd6.tar.bz2
gentoo-158eb9410e0a9b325002840a3168454675ed0cd6.zip
dev-python/guessit: Remove 9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/guessit/guessit-9999.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
deleted file mode 100644
index 150c82479b96..000000000000
--- a/dev-python/guessit/guessit-9999.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python library for guessing information from video filenames"
-HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.org/project/guessit/"
-EGIT_REPO_URI="https://github.com/guessit-io/guessit.git"
-EGIT_BRANCH="develop"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS=""
-
-RDEPEND="
- >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
- >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable benchmarks as they require unavailable pytest-benchmark.
- rm guessit/test/test_benchmark.py || die
- sed -i -e "s|'pytest-benchmark',||g" setup.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- distutils-r1_python_prepare_all
-}